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Read Me First

Welcome to Take Control of Managing Your Files, version 1.0, published in December 2020 by alt concepts inc. This book was written by Jeff Carlson and edited by Joe Kissell.

This book helps you take on the daunting task of organizing digital files and folders on your devices and teaches you how to effectively organize, locate, and clean up the clutter.

If you want to share this ebook with a friend, we ask that you do so as you would with a physical book: “lend” it for a quick look, but ask your friend to buy a copy for careful reading or reference. Discounted classroom and user group copies are available.

Copyright © 2020, Jeff Carlson. All rights reserved.


Updates and More

You can access extras related to this ebook on the web (use the link in Ebook Extras, near the end; it’s available only to purchasers). On the ebook’s Take Control Extras page, you can:


	Download any available new version of the ebook for free, or buy any subsequent edition at a discount.


	Download various formats, including PDF, EPUB, and Mobipocket. (Learn about reading on mobile devices on our Device Advice page.)


	Read the ebook’s blog. You may find new tips or information, as well as a link to an author interview.




If you bought this ebook from the Take Control website, it has been added to your account, where you can download it in other formats and access any future updates.



Basics

Managing digital files is a task on any system, but for this book I’m focusing on working with Apple’s Mac, iPhone, iPad, and iPod touch products. More specifically, the material covers working in macOS 11 Big Sur, iOS 14, and iPad OS 14, though the features I describe are present in recent versions of the operating systems. Big Sur in particular has a new look and feel from earlier macOS releases, which you’ll notice in the screenshots, but the functionality is similar. I’ll point out differences as they come up.


Understand Paths

Also, this book frequently uses path nomenclature to indicate folder locations. If you’re unfamiliar with this style, it compactly describes the hierarchy of folders starting at the base (sometimes called the “root”) level of the computer system, with folders and subfolders added as you read from left to right. The computer’s internal SSD or hard disk is named Macintosh HD by default (although that can be changed). One important folder at the top level is Users, and inside that is the home folder (bearing your short username) that contains data specific to your user account on the computer. In path form, that structure looks like this:

Macintosh HD/Users/your-username

In macOS, you access files and folders in an application called the Finder. Most of the files you work with are stored in your home folder; the first two levels (Macintosh HD and Macintosh HD/Users) contain system files and other folders that you rarely need to worry about, so we generally don’t mention them. If a path begins with a tilde (~) character, it means the first folder is in your home folder, like so: ~/Documents. To open that folder in the Finder, you’d choose Go > Home, and then open the Documents folder. That’s the same location as:

Macintosh HD/Users/your-username/Documents

To put this into practice: A file that is stored in ~/Documents/Finances/Taxes translates to “open the Documents folder in your home folder, and then open the Finances folder inside it, and then open the Taxes folder inside the Finances folder.”



View Filename Extensions

In Apple’s quest to make computers more approachable, filename extensions are (understandably) hidden by default. You may see a text file named Important, but the actual filename is Important.txt. That filename extension is important to macOS, because it identifies the type of file and which app should open it.

In this book, we’re going to cover some situations where it’s helpful to see the extension, such as when searching for files. So, I recommend you make them visible: choose Finder > Preferences, click the Advanced button, and select “Show all filename extensions.”






Introduction

This book is an acknowledgment of failure.

Not your failure—the failure of our computer systems. I’ve long believed that computers are supposed to make tasks easier, but when it comes to dealing with files, we spend a lot of time and energy simply wrangling documents and folders. Why should we get bogged down in managing them, when there are so many more interesting things we can do?

We don’t have to carry on in the same manual-management way. Strategies exist for getting a handle on it all, including taking advantage of features in macOS, iOS, and iPadOS that can make file management easier. Good organization is also about identifying which approaches work best for you, and prioritizing your needs as well as your data.

In this vein, it’s important to keep in mind that we’re all different. Some people don’t want to deal with files at all. Some develop extensive folder hierarchies. Some are fine with what Apple provides, but don’t know what the operating systems are capable of. It’s impossible to hit every possibility in one book, but I’ll do my best to present you with options as appropriate.




Quick Start to Managing Your Files

I’ve structured this book in a top-down manner, the way you’d approach a digital map in the Maps app. It starts up high, looking at general concepts and asking you to consider your goals. From there it zooms in to more specific topics and tasks, from examining organizational strategies to searching for files and cleaning up clutter.


Set goals and strategies:


	Before we click or touch a single file, it’s important to Answer Key Questions about the scope of the task and also about your own preferences so you can Set Goals effectively to managing your files.


	With that knowledge, Develop Strategies that Work for You to help you wrangle files, from building consistent folder hierarchies to applying tags. Also, learn the implications of syncing files among devices and how to choose between external and internal storage.






Start organizing:


	It’s time to get practical, starting with efficiency. Create Priority Shortcuts to access your most important files and folders quickly.


	Just as you navigate your home using a mental model of its floor plan, you need to Understand the Layout of where macOS, iOS, and iPadOS store files. In macOS especially, Understand the Desktop and the role it plays in syncing with iCloud Drive.


	Learn how to Organize Using Files and Folders and also how to Organize Using Tags so you can incorporate those actions into your file management strategy.


	If you think this means you’ll be spending all your time pushing files around, think again. When you know how to Automate File Organization, you’ll save time and remove stress while meeting your goals.






Search for anything


	The work you put into organizing your files pays off when you Find Files in macOS using Spotlight searches, smart folders with multiple criteria, and third-party search apps.


	Spotlight isn’t as robust on Apple’s mobile devices, but you’ll discover it’s more capable than it first appears when you Find Files in iOS and iPadOS.






Cut the clutter


	Organizing is largely about how to deal with incoming files, but the lessons you learned can be applied to what’s already on your computer. Set a Cleaning Strategy for tackling the task of dealing with old files and eliminating duplicates.


	Learn how to Free Up Storage Space, the natural byproduct of having an organized system for managing your files.








Set File Management Goals

The practical, orderly side of me wants to get straight to the step-by-step details of managing files. But first, let’s talk about you.

Why invest your time managing digital files when it would be easier to just toss everything onto the desktop, or leave things where they are already? I see three possibilities:


	You want quick access to important files, such as those for projects you’re actively working on.


	You want to be able to find anything on your computer or mobile device without hunting and pecking through folder hierarchies to do it. Or, perhaps you need to make sure someone else can access your files easily.


	You want to reduce clutter, archive old files, and ease any mental anxiety that comes from working in a messy environment. You may feel as if your files have gotten out of hand, or you’ve put off organizing them for too long. Alternately, you may not want to do any of this, but you realize you need to do it.




If you’re like me, your reaction is: “Yes, I want all of that, please! Preferably as soon as possible.”

To get there, I’m going to repeatedly come back to the concept of priority.

We tend to think of files and folders as items that must be placed in some orderly fashion on our computers. But that’s just storage. As soon as we get involved in doing something with those files, we introduce two other factors that direct how we interact and manage the files: timeliness and intent.

Think about how things are stored in the physical world. For example, consider something as mundane as hand towels for use in a bathroom.

One option is to store the towels in a box at the back of a closet or storage room in your house. It’s an efficient choice: many towels fit into a box, and the towels aren’t getting in the way as they would if they were strewn about haphazardly. However, this approach isn’t convenient, because when your hands are dripping wet, it’s difficult to easily get to the towels.

A more sensible option is to hang one or two towels on a rack within reach of the bathroom sink, so you can grab them quickly to dry your hands. The remaining towels go into a cupboard or basket in the bathroom to replace the towels that get too wet or dirty. You could still pack some towels in that box in the storage room if you need extras when guests visit.

Both approaches work for storing the hand towels, but the second option is the most timely, and it demonstrates your intent to make the towels available where they’re most useful.

Back to your computer. The files there are just bits of data that can be stored anywhere. It’s what you plan to do with them, and when, that establishes their priority and helps direct you to file management strategies that work for you.


Answer Key Questions

Our next task is to answer three key questions. These will help define what sort of work needs to be done, whether we’re talking about one device or several, and how your current management mindset can be applied to your digital files. After that, we’ll set more specific goals and point to strategies and actions to meet those goals.


What Is the Scope of the File Management?

It’s important to figure out the scope of your current state of file management, so you know where to start improving it. Initially, that scope may seem to be “Everything is a mess and it needs to be orderly!” But that task is too big to start with.

Think about specific situations where working with files has stymied you. That way you can attack the problem in a more focused way. Some examples could include:


	Files that belong to current projects are difficult to find or are spread throughout multiple locations.


	Your desktop has so many files and folders that you’ve forgotten there’s a desktop image behind it all.


	You find yourself repeating actions when accessing files you use on a regular basis.


	It’s difficult to find files in general, even those you recently worked on.


	You want to access files on your iPhone or iPad, but don’t know the best way to do it.


	You have files that haven’t been touched in years, but which you stumble across on a regular basis or need to wade through in order to get to current files.


	You want to make sure your files are backed up and secure.




The narrower the scope of the problem, the easier it is to tackle. You can expand the scope later as needed.

It’s also important to set realistic expectations. In my house I want no clutter, clean rooms, and to know exactly where to find anything at a moment’s notice. However, I also know I’m personally just not wired that way. It’s important to be realistic about your level of organization. You can always work your way up to that state. If you tackle a goal that’s too big at the outset, there’s a strong chance you’ll relapse into old behavior.

Part of this question relates to the mental anxiety I mentioned earlier. We think of “clutter” in terms of stuff, whether that’s disorganized files on the computer or physical objects that seem to have no permanent place. But clutter also manifests as mental strain: I know people whose day-to-day work is impacted by a small percentage of the files on their systems, but who spend a huge portion of their energy worrying about the overall clutter.

So my advice here is to take an honest look at the scope of the problem. If your desktop is littered with layers of icons because you’ve used it as the dumping ground for everything over the years, but you don’t actively use any of those documents, it may be beneficial enough for your mental state to move them all to a folder called “Archive.” Then, you can start with a fresh strategy, and gradually work your way through organizing that backlog, or set up mechanisms that will help you make sense of that data (see Clean Up Your Files).



Do You Use Multiple Devices?

Next, ask yourself a more practical question. Will you be sharing files with multiple devices, such as an iPad, iPhone, other Macs, or Windows machines?

If so, consider setting up cloud services that automatically sync files, such as iCloud Drive, Dropbox, Google Drive, or others. If you’re using iCloud in particular, this choice has organizational ramifications due to how the Desktop and Documents folders are treated. I cover this in more detail in Sync Multiple Devices and Computers.



How Do You Organize Elsewhere?

Although this book focuses just on managing your files, organization happens in other areas of your digital experience. Take a quick look at how you organize email, photos, music, and other collections. That can give you a clue as to how your brain organizes things in general.

Do you compartmentalize and structure information into smaller, organized pieces? Do you rely on searches? Do you randomly browse until you run across what you’re looking for?

As an example, for years I sorted all of my email messages into folders arranged by topics and projects. At some point, I realized I was expending a lot of energy creating folders and manually moving messages to them. Although the system seemed organized, I rarely revisited most of those folders, many of which contained small numbers of items.

Now, using Apple Mail, the messages I need in front of me are in the In box, and everything else—all of it—gets filed to an Archive folder. In some cases I flag important messages, which I can view using a filter. For viewing some recurring information, I create smart mailboxes. I’ve also set up automation for dealing with new messages that I want archived but don’t need to see or act on.

My approach to organizing photos evolved similarly during the same time period. Using Apple’s old Aperture software, I’d move photos into albums dedicated to projects and topics. Now, using Adobe Lightroom as my primary photo library, I let the software import photos from my camera to folders it creates based on the images’ capture dates, and I apply keywords and other metadata to locate the shots later. (I detail my system in Take Control of Your Digital Photos, which also discusses working with Apple Photos and other apps.)

My point is that the system—or the beginning of a system—you should use may already be in front of you. If you’re more comfortable assigning items to folders, even in multiple nests of hierarchies, that could be the way to go. If you want to throw everything into one spot and let macOS find things for you, perhaps features such as smart folders and tags are the way to go.




Set Goals

Now that we know a bit more about you, let’s come up with some practical goals.

It’s important to break down larger goals into smaller pieces. If I approach a goal to “clean my house,” I’m liable to lurch my way through the rooms tackling little bits here and there and run out of steam before I make substantial progress. Instead, it’s better to focus on cleaning just one room, or just one element house-wide such as “pick up everything on the floors” and then move on to “sweep the floors.” Approached piecemeal, the house gets cleaned.

So it is with the files on your computer. I’m using the idea of priority to break out the following suggested goal categories. As I mentioned earlier, everyone is different. Based on the answers you’ve come up with so far, you may want to jump to level 2; or perhaps getting a handle on your archive is more important, in which case you might start with level 3.


Level 1: Quickly Access Important Files

Consider this the route that involves the least amount of preparation and is focused on making sure the files for current projects are prioritized. At this level you would:


	Learn how to use the desktop as a temporary staging area.


	Create Priority Shortcuts for folders you open frequently.


	Use smart folders to spotlight recent or active files, regardless of where they’re stored.


	Employ a document storage app such as DEVONthink or Yojimbo as a catch-all location for important documents.






Level 2: Find Anything

This level takes advantage of the search capabilities of your devices to locate files beyond just their filenames. To do that, you would:


	Create and stick with a scheme for storing files in consistent folder hierarchies you can navigate easily.


	Learn how to perform Spotlight searches (and whether you should consider renaming your files).


	Add valuable metadata by assigning tags to files and folders.


	Use smart folders to specify the information you wish to find.


	Go beyond Spotlight using third-party search utilities.






Level 3: Reduce Clutter and Deep Clean

Part of reducing clutter is setting up a system that doesn’t encourage it in the first place. At this level, you would:


	Use automation to handle file organization tasks without your involvement.


	Locate and remove duplicate files.


	Free up storage space by removing or relocating cumbersome files and folders.




From there, you can build strategies to get them done.






Develop Strategies that Work for You

With file management goals in mind, we can build strategies for reaching them. In this chapter, we’re going to tackle high-level file management before moving into the specifics of organizing in the next chapter. That includes an overview of approaches such as grouping files and folders, applying Finder tags, and using search features.

We’re also covering two other important considerations: syncing files among multiple devices and computers, and choosing which files to store on your computer’s internal storage versus external storage such as a hard drive or NAS (network attached storage) device. Plus, no book about files is complete without mentioning backups!


Consider File Management Strategies

I’m breaking out the following strategies as separate approaches, but in reality you’ll likely end up using aspects of each as you determine what’s most effective for you.


Group Files by Project or Topic

This management system uses the hierarchical folder structure of the Finder to organize your files by project, topic, or other criteria. macOS does some of this for you already, providing folders such as Documents and Pictures (see Understand the Layout), but you can implement your own structure if you choose.

For example, on my computer, I keep nearly all of my business files in a folder called Never Enough Coffee (the name of my company). When I start a new project or gain a new client, I create a new folder inside that folder.

The way you name and organize these nests of folders depends on how your projects are set up. In my case, when I write an article for an outlet such as DPReview, I make a new folder inside the client’s folder, creating a directory like this: Never Enough Coffee/DPReview/Affinity Photo for iPad (Figure 1).


[image: Figure 1: This hierarchical nest of folders leads me quickly to a project I worked on.]Figure 1: This hierarchical nest of folders leads me quickly to a project I worked on.

The key to this strategy is consistency. You’re able to traverse folders logically without pausing to remember where you may have saved something at one point. For instance, if you need to find a tax document from 2018, you know it will be in a directory such as ~/Documents/Finances/Taxes/2018 Taxes.



Apply Tags

I’ll admit I was not an early adopter of using tags; in fact, initially they annoyed me. For years I’d used Finder labels to color-code folders based on their status: in general, yellow meant I’d completed a first draft, red indicated that the work had been reviewed, and purple noted that part of the project was completed. I could see at a glance the status of the various pieces.

But in OS X 10.9 Mavericks, Apple introduced Finder tags, small text descriptors that can be assigned to files and folders. Those color labels were turned into tags with preset color values. Now, a tag can be any word or phrase, and any tag can be assigned one of the seven colors—which seemed like more clutter, to me.

Tags, however, turn out to be a powerful feature for managing files that aren’t bound by the hierarchical folder system. Tags let you store files anywhere, and bring them together with a bit of shared metadata using Spotlight searches or smart folders.

For instance, documents that are stored in dedicated app folders on iCloud Drive, such as Keynote presentations, can stay put where they’re easily accessible to all your devices. Media assets and other project files can be stored elsewhere. You can then view them all together using a smart folder, search, or by selecting a tag in the sidebar (Figure 2). This approach is also good in macOS if you use several cloud services, where files must remain in their dedicated folders (like Dropbox or Google Drive) in order to sync properly; in iOS and iPadOS, however, tags aren’t consistently recognized in services other than iCloud Drive. See Organize Using Tags.


[image: Figure 2: These files are saved in several different folders, but share the same “jetpack” tag.]Figure 2: These files are saved in several different folders, but share the same “jetpack” tag.



Lean on Search

Perhaps creating folders and applying tags still sounds like too much. Your files are bursting with metadata and content, which you can identify by performing searches.

That could be as simple as typing a term using the system-wide Spotlight interface, or as intricate as creating smart folders that automatically update their contents based on several criteria. On the surface, Spotlight seems like a straightforward search field, but there are many other criteria and methods of narrowing the results.

So far we’re also talking only about searching in the Finder. There are also utilities that work with the Spotlight index or on their own to help you find what you’re looking for. See Find Your Files.




Sync Multiple Devices and Computers

If you want to open your files on more than one device as opposed to using just one computer, you need to adopt a modified mindset. Synchronizing files requires a little more planning and forethought, but once you understand the basics of how it works, it’s easy to incorporate syncing into your system.


Understand Cloud Architecture

Long ago, my solution for having a desktop computer and a laptop computer involved connecting them with a cable and running an app that mirrored the contents on both machines. Now, most solutions involve syncing files through a cloud service such as iCloud or Dropbox, particularly if you want the files on an iPad or iPhone.


Note: My old sync setup isn’t ancient history. If you’re syncing files between computers on the same local network, you can do it without connecting to a cloud service, as I discuss ahead in Choose Sync Solutions.


With a cloud service, files and folders are copied and stored on computer servers located elsewhere. Sometimes those computers are owned by the service, but more often the storage is pooled among machines that could be anywhere—hence the idea of storing files in an amorphous “cloud.”

When you connect another device or computer to the cloud service, the files you’ve chosen are copied to its local storage. As changes are made on one device, they’re synchronized to the cloud copy and then updated on the other devices (Figure 3).


[image: Figure 3: Files in the cloud are copied to computers or made available to apps on devices.]Figure 3: Files in the cloud are copied to computers or made available to apps on devices.

Each of the major services creates a folder in the Finder, and only the files you move into that folder are synced. Trying to sync everything on the computer would require vast amounts of cloud storage, bandwidth, and time.

The services also feature a helpful exception to the diagram shown in Figure 3. After your files have been copied to the cloud, you can activate selective sync options that control which of those files are kept on the local storage. Using Dropbox’s Selective Sync option, for example, I’ve excluded some of my old Take Control book projects that I no longer need on my computer. If, for some reason, I need to access those files again, I can do so by using the Dropbox website or by reactivating the hidden folders. In iCloud Drive, you can turn on Optimize Mac Storage, which automatically removes local files as needed to conserve space and re-downloads them as needed.


Note: One cloud service that does copy everything on your computer is Backblaze, but that’s designed for remote backup, not active sync.


On my Mac, I store nearly all of my work files in a Dropbox folder within my home folder (Figure 4). That lets me open active files from any of my devices, and also gives me an automatic backup of my important data.


[image: Figure 4: Dropbox is just a folder within my home folder, but it has magic syncing powers. You can see I also have a Google Drive folder that accomplishes the same goal in its own Google silo, and an OmniPresence folder that stores documents created by apps developed by The Omni Group (such as OmniOutliner).]Figure 4: Dropbox is just a folder within my home folder, but it has magic syncing powers. You can see I also have a Google Drive folder that accomplishes the same goal in its own Google silo, and an OmniPresence folder that stores documents created by apps developed by The Omni Group (such as OmniOutliner).

One thing to keep in mind, though, is that each service imposes its own storage limitations. As examples: the Dropbox Basic plan includes 2 GB of storage for free; a basic iCloud account includes 5 GB of storage; and Google Drive includes 15 GB of storage for free. When you reach those limits (which can include other data, such as iPhone backups and photos), you’ll need to upgrade to a paid storage plan.




Clearing Up a Cloud Misconception




One common misconception I hear quite often is that when files are copied to the cloud, they exist only in cloud storage; that if you aren’t connected to the internet, you’re out of luck.

In truth, the files copied to the cloud are typically replicated on all the devices connected to the service. (The exception is if you activate features that sync only some of the files, such as Selective Sync in Dropbox or optimized storage in iCloud; see Optimize Mac Storage.) If you’re traveling where there’s no internet access, and therefore no cloud access, you can still work on the local versions of your files. The changes will be synced to the cloud and other devices when the connection is reestablished.




Choose Sync Solutions

When looking at which services to use for syncing consider the following factors:


	Storage Amounts and Cost. The amount of storage offered at the free tiers for these services varies, but look at the cost to increase that amount. In the United States, jumping from iCloud’s free 5 GB of storage to 50 GB costs just $0.99 a month; 200 GB costs $2.99 a month; the 2 TB level is $9.99 a month; and there are also bundled amounts that go with the Apple One subscription plans.

Dropbox’s comparatively meager 2 GB allotment on the free plan jumps to 2 TB for the Individual Basic plan, but that costs $9.99 per month.


	Other Features. Check if any services you currently pay for already include cloud storage. The Microsoft 365 individual plan includes 1 TB of storage for one person for $6.99 a month, but you’re also getting the full Microsoft Office suite of apps. Dropbox and Google Drive can also automatically back up photos and other data.


	Silos. Most of these services provide a data bucket you can throw anything into. Microsoft Word files can live in Dropbox folders, for instance. But that’s not always the case. Google Docs files may not launch successfully from a Dropbox folder, for instance. A more specific example is Adobe’s Creative Cloud, which is used to share images and assets between Adobe’s applications. Lightroom automatically uploads images to Creative Cloud, but they don’t appear in the Creative Cloud Files folder. Nor can you easily store Lightroom images in a Dropbox folder to get around Adobe’s storage limits.


	Services You Share with Others. If your employer or clients already use a service, you may need to stick with that one for the most compatibility and least amount of friction. My podcast cohost Kirk McElhearn and I share a Dropbox folder, which ensures that we both have the latest versions of the files we create (like the audio recordings and images files for the website) on all our machines.




It’s likely you may use more than one service. Make sure you’re consistent about what you use them for. In my case, I primarily use Dropbox for cloud storage because I’ve relied on it for years and I have an organizational system set up. I also take advantage of iCloud storage for apps, particularly when switching between my Mac and my iPad, but I don’t really use the general pool of iCloud Drive storage much because that need is met by Dropbox. Similarly, I rarely touch Microsoft OneDrive, even though I pay for Microsoft 365 to use compatible apps with some of my clients.


Tip: I’m preaching simplicity here, but if you’re skirting the upper edges of cloud storage and don’t want to pay for more, you can separate your files among the free tiers. Just make sure you know which files are stored where to avoid confusion later.



iCloud Differences

Earlier I mentioned that choosing iCloud as a cloud service has implications for the rest of your organizing strategy, so now it’s time to explain. It’s likely that iCloud Drive was enabled during a system update. If it isn’t, go to Apple  > System Preferences > Apple ID > iCloud (Big Sur and Catalina), or Apple  > System Preferences > iCloud (Sierra through Mojave), and enable iCloud Drive.

With Dropbox, Google Drive, and other services, there’s a clean dividing line between files you sync and the rest of the contents of your computer: whatever is in the service’s folder gets copied to the cloud. iCloud, because it’s the default option for macOS, iOS, and iPadOS, takes a two-pronged approach:


	To differentiate iCloud Drive from other folders, Apple makes it available in the sidebar in Finder windows (Figure 5); you can also bring up an iCloud Drive window by choosing Go > iCloud Drive in the Finder. Files stored in iCloud Drive act like most services, where anything copied there is uploaded to the cloud and available to other devices. It’s also where Apple’s iWork apps prefer to store their documents, and where some mobile apps on iOS and iPadOS save files; see Understand the Layout.


[image: Figure 5: iCloud Drive appears in the iCloud list in the sidebar of Finder windows.]Figure 5: iCloud Drive appears in the iCloud list in the sidebar of Finder windows.


	You can optionally sync the Desktop and Documents folders using iCloud. If you’ve previously used those locations to store your important files, all your devices can access them without having to move any files to a new location. This option is not turned on by default, and of course you need to have enough storage allotted to your iCloud plan to accommodate the files. The folders then show up in the iCloud Finder sidebar, not your home folder, but due to some Apple sleight of hand, the desktop behind your Finder windows still looks the same. (See Understand the Desktop for more detail on how the desktop works differently than most folders, and to learn how to activate this feature.)






Cloudless Sync

What if you want to sync files between devices, but not bounce them through a cloud server? Resilio Sync Home securely copies data using peer-to-peer technology (it was formerly BitTorrent) to other computers, mobile devices, and even native clients for NAS devices on your network.


Tip: In iOS and iPadOS, the Resilio Sync app registers itself with the built-in Files app. You can view files and folders in the Sync app, but to open them in associated apps, such as spreadsheets in Numbers, open the Files app and access them from there.


There are also more traditional sync utilities where you specify a source and a destination, and then the app copies what’s needed to ensure that the contents in both locations match. ChronoSync has been a stalwart on the Mac for years and includes options for scheduling direct sync operations as well as making more comprehensive backups.





Choose Between External and Internal Storage

We store more files than ever, but depending on which computer you own, you may have less space to keep them. The tradeoff for using Macs with extremely fast solid-state storage (most often referred to as SSD, or solid-state drive), which is most of the lineup now, is that most of the internal drive configurations feature capacities starting at 256 GB or 512 GB—and some models sold by third parties still ship with 128 GB of storage. If you’re willing to pay a premium, you can configure a Mac with a higher-capacity SSD (up to 8 TB on the iMac or Mac Pro, for only an extra $2,400!), but you have to make that choice when you buy the computer. Meanwhile, for less than $200 you can buy an external 8 TB mechanical drive (with spinning magnetic platters) that connects via USB.

At some point, you’ll have to decide which files stay on your internal drive and which get shunted off to an external location.

First, we need to take into account how convenient it will be to access external files. The simplest solution is to connect an external drive and copy files to it. If you use a desktop Mac where the drive can be always connected, the impact isn’t as disruptive. But if you’re a laptop owner who wants the freedom of not always being tethered to other equipment, you may lose that constant file access.

One option is to sync files to a cloud service, which makes them available wherever you have an internet connection (see Understand Cloud Architecture). If storage space is a concern on your laptop, you can selectively sync files you don’t anticipate needing on a regular basis.

Another option is to set up a NAS and mount its volumes over the network as if it were physically attached. With a NAS, in most cases you can also access those files over the internet when you’re outside your local network.


Note: For more on disks and storage (including NAS), see my book Take Control of Your Digital Storage.


I can think of a few situations where external storage would apply:


	You keep an archive of old files that you don’t regularly need on a capacious external disk or NAS.


	You work with large files, such as video or audio recordings, or thousands of photos, which can’t all exist on your computer’s internal storage. You could connect a fast drive and store the media files there, and point your editing software at them. Or, for performance reasons, you might store most of the files on the external drive and copy active ones to your internal storage, which is nearly always faster than external storage.


	You may work on projects where it’s most convenient to share a physical drive with other collaborators instead of using cloud storage (such as if the files are too large to economically upload and download).





Note: None of these examples are considered backups. If you introduce external storage to your setup, make sure you have a way to also back up those files.


To determine which files belong on the internal storage versus an external location, think about priority. Files you’re currently working on, or those you reference regularly, stay on the internal storage, while older files you haven’t touched can be moved to the external. Create a smart folder that locates files with modification dates older than, say, three or six months ago to help identify likely candidates (see Clean Up Your Files).

If you organize using hierarchical folders, it’s easy to replicate the same structure on the external disk and then move projects over when they’re completed. If you primarily rely on tags and Spotlight searches, the folder structure isn’t as important—but it’s a good idea to approximate what exists on the internal storage.

There’s a performance issue at play when it comes to storage location, too. The SSDs in modern Macs are extremely fast, so you’ll get the best performance if the files you need to access are on the internal storage, particularly if you’re working with larger ones like photo, video, or audio files. If your external disk is also an SSD, you may not notice as much of a difference, certainly not compared to reading and writing files from an external mechanical disk.


Note: I’m focusing mostly on organizing files to meet your current needs, but it’s also important to think further ahead. Joe Kissell’s book Take Control of Your Digital Legacy helps you plan what happens to your files after your passing.




Back Up Your Files

I think every Take Control book I’ve published includes a section on making backups, for good reason: You can have the best organizational system in the world, but it won’t matter if those files evaporate due to a failed hard disk.

For the best discussion of backups, go get Take Control of Backing Up Your Mac. For our purposes, here’s a general overview of what a solid backup system should look like.


Note: At publication time, Take Control of Backing Up Your Mac is a bit outdated, but a new edition that will fully cover Big Sur and Catalina is in development, with publication expected in early 2021.


The idea behind backups is to have multiple copies of all your files, so if something bad happens, you don’t lose any data, and you’re able to get back up to speed without much disruption. Ideally, a backup system has at least three parts:


	A local versioned backup, such as a Time Machine disk, that regularly makes copies of recently changed files. Multiple versions of files are stored, enabling you to revert back to, say, the state of a document from yesterday. Since Time Machine is a feature baked into macOS, this is the easiest option.


	An offsite backup of some sort. This can be a second bootable clone or Time Machine disk that you store in a safe deposit box, office, or friend’s house. It could be a cloud backup service such as Backblaze, or Dropbox’s computer backup feature, which is a separate feature you must opt in to. I’ll even go so far as to say that syncing your important files with the cloud in Dropbox, iCloud Drive, or Google Drive (or any of the others) is better than nothing. The offsite backup preserves data in the event your local copies are lost due to fire, flood, or other physical damage.


	A bootable clone of your computer’s startup volume, which includes all system files as well as your documents and other files. If the storage in your Mac stops working, you’ll be able to start up the computer from this clone and continue working. A Time Machine backup, by contrast, can’t run the computer; you first need to install a clean version of macOS and then restore the data, which takes time. For the best performance, get an external SSD (solid state drive) that matches the capacity of your startup volume.

That said, as of Big Sur, it’s more difficult to make a bootable backup than in earlier releases. Due to security changes at the fundamental levels of the operating system, Apple only recently updated its internal tools to create a bootable backup, and not all backup utilities have been updated to support it. Also, as of macOS 11.1, it’s not yet possible to make a bootable backup of a Mac running Apple’s M1 processor.




If you currently have no backup system, this might look like overkill, but believe me, if (or when) a drive or computer fails, it will have been worth it. At the very least, buy an inexpensive external hard drive and set it up as a Time Machine disk.





Organize Your Files

To find something in a house or apartment, we start with a mental model of the place. Let’s say I’ve misplaced my keys, which in my house are usually kept on a table by the door. It’s more likely I set them down in the living room or kitchen than in the dining room or bathroom, but they could also be in my bedroom, in the pocket of the pants I wore yesterday. With that quick map in my head of the most likely places, I can start searching.

Similarly, it helps to have a mental model of where files are located on your devices, too. Apple does some of this work for you by creating folders in macOS for Documents, Pictures, Movies, Downloads, Music, and other categories; in iOS and iPad OS, files are generally stored with the application that created them or in dedicated iCloud folders (depending on the app) accessible through the Files app.

What’s different about the computer compared to a house is that it includes mechanisms for helping you locate what you want. In our real-world analogue, imagine asking out loud “Where are my keys?” and having a team of people go search all the rooms for you. Sounds nice, doesn’t it?

In this chapter, we’re going to Understand the Layout of files and folders in macOS, iOS, and iPadOS. That includes the need to Understand the Desktop, which behaves different from most locations. We’ll also learn how to organize your files using groups and hierarchical folders, learn how to Organize Using Tags effectively, Automate File Organization to let the computer do some of the work for you, and look at how to Use Information Management Apps for non-Finder approaches.

First, though, let’s emphasize high-priority items by creating shortcuts that can help your file management immediately.


Create Priority Shortcuts

This section is all about getting to your important data quickly, regardless of whether you’ve chosen to organize your files by hierarchical folders, tags, or transmissions from deep space.


Add Items to Finder Windows

When I start a new project, its folder immediately goes into the sidebar of every Finder window. To get to those files quickly, I can create a new window and click that folder in the Favorites list. Here’s how to do it:


	Open a new Finder window by choosing File > New Finder Window, or pressing ⌘-N.


	If it’s not already visible, expand the Favorites list by clicking the disclosure  icon that appears to the right of the name when you move your pointer over it.


	Navigate to the folder you want.


	Drag the folder to a spot in the Favorites list (Figure 6). Or, choose File > Add to Sidebar (which adds the item to the bottom of the list).





[image: Figure 6: Drag a folder to the Favorites list in the sidebar.]Figure 6: Drag a folder to the Favorites list in the sidebar.

Some people find the sidebar takes up too much space. For a slight improvement, go to System Preferences > General and set “Sidebar icon size” to Small. Or, you can toggle whether it’s visible or not by choosing View > Hide Sidebar and View > Show Sidebar—but that’s adding more work, isn’t it?

Alternatively, items can be added to the toolbar at the top of the window. Admittedly, this space is more constrained, but if you want quick access to just one or two items, do this:


	Open a new Finder window that contains the item you want to add.


	Hold the ⌘ key, drag the item to the toolbar, and release the key in the spot where you want the item to appear.




To remove objects from either the sidebar or the toolbar, do the opposite steps:


	Drag the sidebar item out of the Finder window until you see the Remove  icon on the pointer. Or, right-click (or Control-click) it and choose Remove from Sidebar from the contextual menu.


	Hold the ⌘ key and drag the item off of the toolbar.






Create Aliases

The precursor to these Finder shortcuts was the alias, a way to make a pointer to a folder or file that exists in another location. For example, you could make an alias on the desktop of a project folder inside your Documents folder; double-clicking the alias opens the original folder.

This technology persists: select an item and choose File > Make Alias; choose Make Alias from the contextual menu; or (the most direct method) hold ⌘-Option while dragging the original item to a new location. Another benefit is that aliases are resilient: if you move a folder to a new location, the alias will still open it correctly.

Personally, I prefer to put frequent folders in the sidebar of Finder windows, because the shortcut is right there whenever I open a new window. An alias is another item that lives in a specific place that must be navigated to.



Add Folders to the Dock

Another place to stash a folder or file shortcut is the Dock, although because there ends up being little real estate on the strip, it’s best to use it sparingly. In fact, I’m going to go so far as to chalk it up to one of those ideas that sounds neat but doesn’t hold up well in practice.

To add a folder to the Dock, drag it to the right side (if the Dock is at the bottom of the screen, the default) or to the bottom side (if the Dock is positioned at the right edge of the screen, as nature intended). When you click the folder in the Dock, its contents pop up as a fan shape, or list, or a grid of icons (Figure 7).


[image: Figure 7: Access the contents of a folder from the Dock.]Figure 7: Access the contents of a folder from the Dock.


Note: The fan option appears only when the Dock is at the bottom of the screen. And honestly, it’s lame. If there are many items in the folder, you see only some of them, with an option to open the folder in the Finder—which is the problem we’re trying to work around.


Initially, macOS chooses which appearance the contents should take based on what’s in the folder. The most versatile, however, is the list view, because it enables you to drill down through multiple folders in the same menu (Figure 8).


[image: Figure 8: Dig into nested folders from the Dock using the List view.]Figure 8: Dig into nested folders from the Dock using the List view.

To choose which style to use, right-click (or Control-click) the folder and choose List under “View content as.”


Tip: This is madness, but worth trying at least once: In the Finder, choose Go > Computer, and then drag your computer’s hard drive to the Dock. Make sure List is selected as the content view. You can then navigate the entire hierarchy of your Mac from the Dock!




Quickly Navigate the Folder Hierarchy

Remember that mental map I mentioned at the beginning of the chapter? It’s one thing to start at the front door of your house and know how to get to any room, but once you’re inside, you also need to know how to traverse the space from room to room. (Let’s just imagine we live in an opulent mansion to make the metaphor work better.)

So it is with navigating your Mac. Particularly if you have multiple nested folders, it’s helpful to know where you are in the hierarchy. There are a few ways to do that:


	In the Finder, choose View > Show Path Bar (Figure 9). It displays the folder structure starting with the volume name.


[image: Figure 9: The Path Bar reveals the current folder’s location at a glance.]Figure 9: The Path Bar reveals the current folder’s location at a glance.


	Select an item in the current window and choose Go > Enclosing folder to move up one level of the hierarchy. Even better, and a shortcut I use all the time, is to press ⌘-↑.


	Hold ⌘ and click the title of the Finder window to reveal the folder hierarchy (Figure 10).





[image: Figure 10: Quickly navigate the hierarchy by ⌘-clicking the Finder window title. In macOS Big Sur, the title is part of the toolbar (top). In earlier versions, the title appears above the toolbar (bottom).]Figure 10: Quickly navigate the hierarchy by ⌘-clicking the Finder window title. In macOS Big Sur, the title is part of the toolbar (top). In earlier versions, the title appears above the toolbar (bottom).


Tip: You can add a Path  pop-up menu to the toolbar that does the same thing as ⌘-clicking the title (choose View > Customize Toolbar). However, conserve space and don’t bother with the menu.




Use the Recents View

The Recents view in the Finder is a special built-in smart folder that displays all recently opened files. Choose Go > Recents or choose Recents in the Favorites sidebar list. This view sounds like a good idea, and it’s the default option for new Finder windows. However, I find it to be a mess (Figure 11).


[image: Figure 11: The Recents view lists files based on when they were last opened.]Figure 11: The Recents view lists files based on when they were last opened.

For one thing, it shows everything you’ve recently opened, which produces a list that must still be hunted to find what you’re looking for; in Figure 11 there are more than 4,000 items. Thankfully, the files are sorted, but the default sort mechanism is Date Last Opened, which is not necessarily the same as the last item you last worked on. (That applies to the Icon and List views; the Column and Gallery views sort by file name.)

For example, to create Figure 10 earlier, I opened two screenshots in Adobe Photoshop, placed them in one document and arranged them for comparison, and then saved the file in the Photoshop .psd format. Since I didn’t open that file—I created it—it doesn’t show up in the Recents list. I’m more likely to edit the Photoshop file later if I need to adjust the figure, not the individual screenshots.

With that off my chest, the good news is that you can do a couple of things to make the Recents view more helpful:


	Change the sort order. Choose View > Sort By > Date Modified. You can also hold Option and click the Group By  icon on the toolbar to choose a method.


	Use Groups. This option is better if your files fall into neat types, such as presentations and spreadsheets. Instead of wading through everything, the Finder displays items based on their kind. (If your files aren’t so discernible, you may find yourself digging through groupings such as Documents or Other.) Choose View > Use Groups, or click the Action  icon and choose Use Groups (Figure 12).





[image: Figure 12: Viewing the Recents window by groups can be helpful.]Figure 12: Viewing the Recents window by groups can be helpful.

I do occasionally reach for the Recents window, so I’m not dismissing it outright. If you find yourself frequently wanting to access recent files, though, creating smart folders gives you more control over what appears.

To change the default view to something other than Recents, choose Finder > Preferences > General and choose a different location in the New Finder windows show pop-up menu. (I prefer to use my home folder, but you can pick any folder.)


Note: Hang on, what about the desktop as a priority location? Isn’t the point of it to grab files without navigating folder structures? I discuss more in Understand the Desktop.


The Recents view in the Files app in iOS and iPadOS works pretty much the same way, but with a few limitations:


	Only files in iCloud Drive show up in the Recents view. So even though you can access Dropbox or Google Drive files in the Files app, Recents doesn’t check them for updates.


	On the iPad, you can change the view type (icons, list, columns) and sort order, but the Date option is limited to just the modified dates of files; tap Date to reverse the sort order (Figure 13). The Recents view in the Files app on the iPhone displays items only by icons with the most recent items at the top.





[image: Figure 13: Viewing recent files in the Files app on an iPad.]Figure 13: Viewing recent files in the Files app on an iPad.




Understand the Layout

First, files can go almost anywhere—the notable exceptions are the root level of your Mac and especially the System folder, which isn’t really a place you should be poking around anyway. To act as a bulwark to chaos, however, macOS includes folders dedicated to some types of files. This structure is partly to help you organize things, such as putting audio files in the Music folder even though you can store them anywhere. But the system also uses it for some specific needs. In iOS and iPadOS, things are more regimented, largely due to security concerns.


Where macOS Puts Files

Let’s take a quick top-down look at your Mac’s files.

The root level of your Mac contains four folders: Applications, Library, System, and Users (Figure 14).


[image: Figure 14: This is the top level of your Mac.]Figure 14: This is the top level of your Mac.

The Applications folder is where apps are stored. The System folder contains the core files that make everything run, and is off limits (for good reason). The Library folder also contains files used to operate the computer, and is a place where developers can include preferences and other files that support their apps. You also have some ability to edit what’s in the Library folder, although it’s rare that you would need to.


Note: In macOS Catalina and later, the system exists on its own read-only volume to prevent malicious software from getting access. My book Take Control of Your Digital Storage covers more about how volumes work under the hood.


The Users folder contains folders for each user you’ve set up in System Preferences > Users & Groups (Figure 15). The folder emblazoned with the home  icon indicates the current user.


[image: Figure 15: The Users folder contains folders for each user account you’ve set up, including Shared, which macOS creates.]Figure 15: The Users folder contains folders for each user account you’ve set up, including Shared, which macOS creates.

It’s within your user folder—more commonly referred to as your home folder—where the files you control are stored (Figure 16).


[image: Figure 16: The files you interact with are found in the home folder.]Figure 16: The files you interact with are found in the home folder.

Most of these seem self-explanatory, but let’s run through them:


	Desktop: Although the desktop shows up as the background layer of your Mac’s screen, structurally it’s a folder. See Understand the Desktop for more details. If iCloud Drive syncing of the Desktop and Documents folders is turned on, this folder is moved to iCloud Drive (see Sync the macOS Desktop and Documents with iCloud).


	Documents: The Documents folder is a massive catch-all location for files. The idea is that you’d store everything that isn’t a movie, music, or image file in Documents. As with the Desktop folder, the Documents folder can be synced with iCloud Drive, which moves it out of the home folder.


	Downloads: When a file is added to your Mac from elsewhere, its default destination is the Downloads folder. That includes downloads from Safari and other web browsers, and files transferred using AirDrop.


	Movies, Music, and Pictures: These folders store each type of media, but more commonly, are homes to the data used by apps based on each medium. For example, the iMovie library and folders created by various video apps show up in Movies; the Music library (or iTunes library in macOS 11.14 Mojave and earlier) is in the Music folder; and the Photos Library used by the Photos app is in the Pictures folder.


Note: If you import photos in the Photos app or another media manager (like Adobe Lightroom), videos you capture end up in the same folder as photos—they’re not separated into the Movies folder.



	Public: The Public folder is used to share files between users on the same Mac or on a network.





Note: You may also see a Sites folder, which was used by Apple’s discontinued iWeb app in earlier Mac OS X releases.


Those are the default folders created by macOS, but you may have others in your home folder. Cloud services such as Dropbox and Google Drive put their folders at the top level of the home folder for easy access.

You can add your own folders there, too. I mentioned earlier that I keep my active work in a Dropbox folder, which gets synced to the Dropbox servers. Sometimes it’s not convenient to use Dropbox, though, such as when I’m working on large video or audio files, or doing testing that doesn’t need to be uploaded to the cloud. For that, I’ve set up a dedicated folder called WinterXData (WinterX is the name of my startup volume) so the work there doesn’t strain my bandwidth unnecessarily.




Packages, the macOS Secret Folders




When you look at them in their respective folders, the iMovie, Photos, and Music libraries each appear to be single files (such as Photos Library.photoslibrary). It’s actually a bit of system trickery: each one is a package, a special type of folder that looks and acts like a file so as to simplify its appearance.

Getting into the package explains the deception. For instance, right-click (or Control-click) Photos Library.photoslibrary and choose Show Package Contents. You’ll see folders such as resources and originals, which include nested groups of files that don’t immediately correspond to the images you would expect to find. Essentially, the app is doing a lot behind the scenes to present what you see in the app’s interface, like creating several sizes of thumbnails and storing metadata about which edits have been applied.

In general, it’s best to stay out of packages unless you’ve been instructed to do so by someone knowledgable. The upside is that you’re not exposed to that complexity in the Pictures folder.




Where iOS and iPadOS Put Files

On a Mac, you put files almost wherever you want, and choose which apps to use to open them. On an iPhone or iPad, you can’t even see any files without opening an app first.

Largely this is a security consideration. Apps are sandboxed to prevent files from interacting with the system or with other apps they shouldn’t (and potentially wreaking havoc). In practice that means apps save their files within their own protected storage spaces.

However, apps can securely share files to approved channels using the Files app architecture. If an app supports it, files can be saved to locations outside the sandbox, such as iCloud Drive (Figure 17).


[image: Figure 17: iOS and iPadOS keep applications siloed, with the Files app architecture acting as a go-between.]Figure 17: iOS and iPadOS keep applications siloed, with the Files app architecture acting as a go-between.

Similarly, apps that work with Files can open files in locations you’ve set up (as I explain just ahead). For example, if a Keynote presentation is stored in a Dropbox folder, within Keynote you can navigate to that folder and open the file (Figure 18).


[image: Figure 18: Within the Keynote app, I’ve navigated to a presentation saved in my Dropbox folder.]Figure 18: Within the Keynote app, I’ve navigated to a presentation saved in my Dropbox folder.

The Files app also lets you access some data that other apps have stored. Select On My iPad or On My iPhone in the list of locations to view the folders of apps that store their files locally (and which support this interaction with the Files app) (Figure 19).


[image: Figure 19: Using the Files app on an iPhone or iPad, you can access files stored in apps’ folders (iPhone shown here).]Figure 19: Using the Files app on an iPhone or iPad, you can access files stored in apps’ folders (iPhone shown here).


Tip: If you need to access files that are not exposed by the Files app, utilities such as iMazing and iPhone Backup Extractor can do the job. I saved dozens of my daughter’s Minecraft worlds from a backup once this way when an update accidentally erased them all.



Configure Locations in the Files App

The Files app can connect apps and services so their files can be shared, but first you must set them up as locations. Here’s how to do it:


	Open the Files app on an iPhone or iPad.


	Tap the More  icon and choose Edit (iPhone) or Edit Sidebar (iPad). A list of possible file sources appears (Figure 20).


[image: Figure 20: Choose which apps and services appear in the Locations list of the Files app (iPad shown here).]Figure 20: Choose which apps and services appear in the Locations list of the Files app (iPad shown here).


	Turn the switches on for the services you use.


	Tap Done.




When you tap one of the new locations you added to view its files, you may have to sign in to your account for that service or open its app to authenticate and grant permission for Files to work with the files.


Tip: When editing the Locations list, drag the  handle to reorder the items. On the iPad, you can just hold a location for a moment and then drag it to a new spot in the list.




Understand the iCloud Drive Downloads Folder

As I discuss shortly in Sync the macOS Desktop and Documents with iCloud, you can choose to sync the Desktop and Downloads folders on your Mac with iCloud, making their contents available on other devices that also sync with iCloud. That precedent creates a little confusion, because the Downloads folder in the Files app on iOS and iPadOS does live in iCloud Drive, but is not related to the Downloads folder in macOS.

This Downloads folder is the repository just for files downloaded using an iPhone or iPad; downloaded files still need to go somewhere, after all. Syncing the macOS Downloads folder would be overkill, since that’s where things like software installers go.

If you want to copy files downloaded on an iPhone or iPad, on your Mac go to iCloud Drive/Downloads (using the sidebar or by choosing Go > iCloud Drive).





Understand the Desktop

Ahh, the desktop. Compared to computer systems that came before, where everything was stored in directories, the desktop offered a visual space comprising your entire screen to drop files that could easily be picked up later. You’ll notice, though, that I didn’t include the desktop when I talked about how to Create Priority Shortcuts. Over the years the desktop has gotten a bad reputation as a digital junk drawer. It’s so easy to stash things on the desktop that it can then become difficult to find what’s there.

The desktop is unique among macOS folders in that it’s both a visual space and a folder. Structurally, files exist in the Desktop folder in your home folder: Macintosh HD/Users/User Name/Desktop. (The location differs if you’ve chosen to Sync the macOS Desktop and Documents with iCloud, described ahead.)

Anything in the Desktop folder also appears on the background layer of the Finder. You can have a Finder window displaying the contents of the desktop on top of the desktop itself, even though the files in each place are the same (Figure 21). That’s most helpful if the desktop is covered by Finder or app windows. If you move or delete a file in one view, it’s also moved or deleted in the other.


[image: Figure 21: The files in the Desktop window are the exact same files that appear on the desktop in the background.]Figure 21: The files in the Desktop window are the exact same files that appear on the desktop in the background.

Perhaps as a response to years of people’s desktops being filled to the brim, some file management strategies encourage you to maintain an empty desktop. It’s a noble goal, especially if you tend to have many Finder windows and apps open that otherwise obscure what’s on the desktop (or if you just can’t abide clutter). I think that option is too extreme, because the desktop can be a great tool for working with current project files, and in some cases for shuttling data among mobile devices (we’ll get to that shortly).

But files on the desktop do tend to accrete over time, which leads us to strategies for managing the mess if necessary.




The Magic of Multiple Finder Windows




When you view the contents of any folder, it’s in a Finder window. And in this sense, “window” is an apt metaphor. We identify any onscreen box containing files as a window, but think of it also the way you would a window in your house. When you look out your living room window, you may see a neighbor’s house. If you look out another window facing the same direction, you don’t see something completely different—it’s another view of the same neighbor.

So it is with Finder windows, which give you multiple views into the same thing. You could open five Finder windows, each one viewing your Documents folder, but with the different subfolders visible. Or, if you have many open windows and need to reach one that might be buried behind other items, such as the Downloads folder, it’s quicker to create a new Finder window and open Downloads there.



Use Stacks

The Stacks feature puts all the items on the desktop into groups based on their type, such as documents, images, and PDF files. All the files are still there, but the clutter is removed. (If you have a small number of temporary items on the desktop, Stacks don’t offer any value.)

In the Finder with no windows selected, choose View > Use Stacks; or, right-click anywhere on the desktop and choose Use Stacks. The items align in columns at the right edge of the screen (Figure 22).


[image: Figure 22: The Stacks feature turns clutter (left) into piles of items grouped according to kind (right).]Figure 22: The Stacks feature turns clutter (left) into piles of items grouped according to kind (right).


Note: Only the desktop offers the Stacks feature. If you want to separate other files based on their types in Finder windows, choose View > Use Groups. That includes viewing the Desktop folder in a window.


Click a stack to view the files it contains; the other stacks push aside to make room (Figure 23).


[image: Figure 23: Clicking the Images stack reveals photos (.jpg), Photoshop files (.psd), and even an animated GIF (.gif).]Figure 23: Clicking the Images stack reveals photos (.jpg), Photoshop files (.psd), and even an animated GIF (.gif).

Sorting by Kind is only one way of viewing stacks. When Use Stacks is enabled, choose View > Group Stacks By and specify a time period, such as Date Modified, or sorted by tags. (If you choose None, the Stacks feature is turned off.)

You can also sort the order in which items appear within the stacks. Choose View > Show View Options and pick a scheme from the Sort By menu. In this way, you retain the way items are grouped, but their order can change; for example, if stacks are grouped by Kind, and sorted by Date Last Opened, the last PDF file you opened appears at the top of the PDF Documents stack when it’s expanded.


Tip: The View Options window is also where you can change the size and spacing of files, whether their icons preview the files’ contents, and how the file labels appear (below or to the right of the icon, and optionally displaying additional information such as image dimensions or video durations).



Tip: Although macOS uses Stacks only for the desktop, the utility Folder Tidy, from Tunabelly Software, accomplishes a similar task for any cluttered folder. Instead of discrete stacks, Folder Tidy creates new folders for file types. You can also choose custom methods of organization.




Sync the macOS Desktop and Documents with iCloud

Here’s another way in which the Desktop folder is different from most others: you can optionally sync it and the Documents folder with iCloud. If you already store most of your data in those folders, syncing them makes all those files available to your iOS and iPadOS devices, other Macs, and iCloud on the web.


Note: By default, this feature is turned off, but some people report that they inadvertently enabled it during a system update without realizing the implications. If these two folders are currently syncing with iCloud on your computer and you want to go back to the previous behavior, read Stop Syncing the Desktop and Documents Folders.


Activating this feature involves several consequences:


	The base level of iCloud storage is the free 5 GB tier, which includes data used for device backups and photos, if you’ve enabled those features. Syncing the folders requires more space, so you will likely need to pay a higher monthly amount to add storage to your plan.


	Activating this option relocates the Desktop and Documents folders from your home folder to the iCloud Drive folder. (I’d built up muscle memory over years that no longer applied, such as opening the Desktop folder: type ⌘-N to create a new Finder window, type de to select the Desktop folder, and then press ⌘-↓ to open it. My solution was to put an alias of the Desktop folder in my home folder, as well as a shortcut in the sidebar of Finder windows.)


	Large files that normally live in the Desktop or Documents folders don’t sync well, because small changes require the entire file to be synced.


	Both the Desktop and Documents folders are synced; you can’t choose just one.


	You can optionally enable Optimize Mac Storage, which replaces some local files with proxies to conserve storage space. The originals are stored in iCloud and downloaded as needed when you want to open them. That means your backup system won’t back up those originals if they’ve already been replaced. This setting applies to the entire iCloud Drive, not just the Desktop and Documents folders.




If you’re already syncing important files using another service like Dropbox, you won’t get as much out of this feature. Alternatively, if iCloud’s storage limits or the design of Desktop and Documents syncing pose problems for you, you may prefer something like Resilio Sync Home, which bypasses the cloud and syncs devices with one another directly on the same network or among devices over the internet.

On the other hand, if you’re already paying for ample iCloud storage (such as through an AppleOne family plan), this is an easy way to get your files onto multiple machines. Before you activate this feature, I suggest taking the following actions:


	Move any large files that would require massive uploads every time a change is made. That includes virtual machine files for apps such as Parallels Desktop or VMware Fusion, which can run into the tens of gigabytes. Another option is to set them to be split into multiple files in the virtual machines’ settings, which lessens the impact somewhat, even though those pieces can still be 1 GB or larger.


	Make sure your current iCloud Drive storage allotment is large enough to handle both folders. In the Finder, select both folders, hold the Option key, and choose File > Show Inspector to reveal the size of their contents. If the number is higher than your iCloud plan, either Clean Up Your Files or upgrade to a different iCloud plan.


	If you’re going to use Optimize Mac Storage (or if it’s already turned on for iCloud Drive), first Back Up Your Files before enabling syncing to ensure that the originals are saved to a local backup.





Enable Desktop and Documents Folders Sync

To sync the Desktop and Documents folders, do the following:


	In macOS 10.15 Catalina and later, go to Apple  > System Preferences > Apple ID > iCloud > iCloud Drive.

In OS X 10.12 Sierra through macOS 10.14 Mojave, go to Apple  > System Preferences > iCloud > iCloud Drive.


	Click the Options button.


	Enable the Desktop & Documents Folders checkbox (Figure 24).





[image: Figure 24: Turn on Desktop & Documents Folders syncing in the iCloud Drive options.]Figure 24: Turn on Desktop & Documents Folders syncing in the iCloud Drive options.

The setting applies immediately, but it will take a while to sync the files and folders depending on the amount of data and your internet bandwidth.


Note: There’s no need to enable syncing the two folders on iOS and iPadOS devices, since they access iCloud Drive directly. The folders simply show up in the Files app.




Sync the Desktop and Documents Folders on Multiple Macs

When you have more than one Mac sharing the same Apple ID (such as an iMac at home and a MacBook Air for travel), syncing the Desktop and Documents folders sounds ideal. Your files are all there on either machine, automatically. However, an annoyance crops up when you first enable syncing: iCloud creates new folders specific to additional machines.

For example, after syncing was enabled on my MacBook Pro (my main Mac), I set my Mac mini (an older model in my office) to also sync. Instead of the desktops of both computers magically merging, a new folder, “Desktop - Yo mini,” appears in the Desktop folder on my MacBook Pro (and a similar “Documents - Yo mini” folder is in the Documents folder).

To combine the Desktop and Documents folders’ files, do the following:


	Select your Desktop folder in the sidebar of a Finder window and then select the other computer’s Desktop folder (Figure 25).


[image: Figure 25: A separate folder for the Mac mini’s desktop files was created when I synced that machine’s folders.]Figure 25: A separate folder for the Mac mini’s desktop files was created when I synced that machine’s folders.


	Move the files from the subfolder to your Desktop folder. If there are any duplicates, you’ll have to sort those manually.


	Delete the empty “Desktop - Mac Name” folder.


	Repeat the process for the “Documents - Mac Name” folder in your main Documents folder.





Tip: When you move a file from iCloud Drive to another location on your Mac, a dialog appears asking you to confirm the move. To get rid of it, choose Finder > Preferences > Advanced and turn off “Show warning before removing from iCloud Drive.”




Stop Syncing the Desktop and Documents Folders

If you choose to stop syncing these two folders, a curious thing happens:


	The official Desktop and Documents folders are put back into the home folder, but they’re empty.


	The Desktop and Documents folders in iCloud Drive are still there, with all their files, but they’re no longer the official ones—they’re just regular folders that happen to share the same names.




This means that, just as you may have had to merge folders manually when activating this feature if you use multiple Macs, you’ll have to do some manual cleanup afterward when turning it off.

Here’s how to disable this feature:


	Go to Apple  > System Preferences > Apple ID > iCloud > iCloud Drive (Catalina and later), or Apple  > System Preferences > iCloud > iCloud Drive (Sierra through Mojave).


	Click the Options button.


	Turn off the Desktop & Documents Folders option.


	In the dialog that appears, click Turn Off (Figure 26).


[image: Figure 26: Nothing like a confusing dialog to tell you that your files are going to be removed but also not removed.]Figure 26: Nothing like a confusing dialog to tell you that your files are going to be removed but also not removed.


	Click OK in the next alert to confirm the change.


	Move the files in the iCloud Drive folders (iCloud Drive/Desktop and iCloud Drive/Documents) to the official Desktop and Documents folders in your home folder.






Optimize Mac Storage

iCloud Drive offers a feature that can temporarily remove files from your Mac as long as they’re stored in iCloud. This can be helpful if your Mac includes a small amount of internal storage, such as 128 GB or 256 GB.

The way it works is mostly unnoticeable. From your point of view, all the files are there, but underneath, macOS has replaced some of them with small placeholders marked with a download  icon (Figure 27). When you open one of those, the actual file downloads from iCloud. (You can also click the icon to download the file without opening it.)


[image: Figure 27: The download icon indicates a file exists in iCloud, but not the local storage. An icon on a folder means at least one file within it has been replaced with a placeholder.]Figure 27: The download icon indicates a file exists in iCloud, but not the local storage. An icon on a folder means at least one file within it has been replaced with a placeholder.

As you might expect, Optimize Mac Storage has a few caveats:


	If you have no internet connection, or if iCloud is unavailable, you can’t access files that were removed to save space. Or, if your connection is especially slow, you’ll have to wait longer for the files to download.


	Backups copy only the placeholders, not the originals.


	macOS chooses which files to replace according to its own algorithms.




To enable the feature, go to Apple  > System Preferences > Apple ID > iCloud > (Catalina and later), or Apple  > System Preferences > iCloud (Sierra through Mojave) and select the Optimize Mac Storage checkbox.


Tip: You can manually remove, or evict, iCloud Drive files from local storage while keeping them in iCloud using the free utility Bailiff.






Organize Using Files and Folders

Now that we have a sense of where macOS, iOS, and iPadOS prefer to store files, let’s talk about where you want them to exist. Consider the time and effort involved both in putting them there and in finding them later.


Set Up Consistent Folder Structures

Choosing where files end up is one of those things that will vary by individual. If you want to follow Apple’s lead, you could store video files in the Movies folder, image files in the Pictures folder, and documents of various types in the Documents folder. Or, you may prefer to create folders and group files based on projects or topics.

As you ponder where those destinations will be, think about how you’ll get there. Will you jump directly to your projects? Will you navigate between several folders? Preferably, you want your files just one or two clicks away. If you want them available on all your devices, you could put them all into a synced folder such as iCloud Drive or another service.

Wherever it is, make sure you can open it quickly. Earlier I mentioned that you can change what appears when you create a new Finder window; instead of the Recents folder, you can choose the home folder instead. Well, that can actually be any folder: choose Finder > Preferences > General, and from the “New Finder windows show” pop-up menu, choose Other and set your preferred location.

The key to all of this is consistency. When you encounter a file, you should know immediately where it goes. And when you need that file later, you’ll know exactly where to look. Consistency also pays dividends if you choose to Automate File Organization.

A quick refresher: to create a new folder in the Finder, choose File > New Folder, or press ⌘-Shift-N, and type a name for it.


Tip: A folder system is especially handy if you need to copy or move files to a USB thumb drive or share with someone via a cloud service, because all the associated materials are ordered together.


In a file/folder scheme, think in terms of hierarchies. Let’s take a look at some examples.


Folders Example 1: Project Hierarchy

Projects of all sorts generate files, whether that’s a work project, school homework, or a household project.

Suppose I’m a student creating a report. This could easily be adapted for someone preparing a presentation, publishing a paper, or other possibilities.

I’d start with one overarching folder, such as “School,” and put it somewhere obvious, like my Documents folder or my Dropbox folder.

Inside that folder would be a folder for the class, and inside that would be a folder for the project, such as (Figure 28):

Rocketeering 101
    Rocket Pack Feasibility paper


[image: Figure 28: A promising start to a project (minus the actual project).]Figure 28: A promising start to a project (minus the actual project).

Projects have many parts, and while it would be possible to toss everything into the project folder, it makes sense to add subfolders for things like images and reference materials, like so (Figure 29):

Rocketeering 101
    Rocket Pack Feasibility paper
        Correspondence-RPack
        Images-RPack
        Research-RPack
        Videos-RPack


[image: Figure 29: Organized folders—feels like the project is almost done!]Figure 29: Organized folders—feels like the project is almost done!

Before we get much further, notice a few things in Figure 29:


	I named the subfolders with something that would make them unique, “RPack,” so that if I do a Spotlight search later, I don’t run into a bunch of folders named “Images” or “Correspondence” in other projects. This is an optional step, of course, but more specificity helps.


	As much as possible, I’m trying to keep the hierarchy simple and logical: the School folder contains the class (Rocketeering 101), which in turn contains the project (Rocket Pack Feasibility paper) and its assets. I didn’t create separate folders within the Images-RPack folder for JPEGs, PDFs, Photoshop files, or the like, because that introduces complexity.


	I’m not adhering to the notion that the Documents folder must include only documents. In this case, Documents is the bin where all of the projects are located.


	Since I’d set up iCloud Drive to Sync the macOS Desktop and Documents with iCloud, I’m also making sure the contents are synced with my iPad, iPhone, and any other computers that share my Apple ID. If I run across some resource when I’m using my phone instead of my computer, for instance, I can add it to the Research-RPack folder.




Consistency, again, is important. I could use this structure for other classes and projects. In fact, I could make an empty set of generic project folders to duplicate and rename when the next project begins. (Even better, I could set up a Quick Action using the Automator app to Create Folder Templates in just a couple of clicks.)



Folders Example 2: Personal Files

This hierarchical approach works for all sorts of situations, not just projects. Nearly all of my house-related bills are paid electronically, and with many of them, the amounts are automatically deducted from my checking account. I still want records, though, so when I’m paying bills I make a point of downloading PDFs of the monthly statements.

A sample folder hierarchy would look something like this (Figure 30):

House
    Utilities
        Waste and Recycling
        Electric Company
        Gas Company


[image: Figure 30: A sample hierarchy for household utility statements follows the same simple, consistent approach as a project.]Figure 30: A sample hierarchy for household utility statements follows the same simple, consistent approach as a project.


Tip: Filing downloaded statements is made much easier using the app Hazel, which I describe in Automate with Hazel.



Note: If you plan to collaborate with other people in documents belonging to Apple’s iWork apps (Pages, Numbers, and Keynote), they must be saved to iCloud Drive. Apple details more information in About collaboration for Pages, Numbers, and Keynote. The exception is if you and your collaborators use the Box cloud service, which supports iWork collaboration.





Consistent Exceptions Are OK, Too




If given the option, I’ll choose simplicity over consistency. For example, every year I update a book about Adobe Photoshop Elements for the publisher Pearson Education. Using my typical folder hierarchy, on my Mac that project would appear in ~/Dropbox/Never Enough Coffee/Pearson/PSE2021 Classroom in a Book.

However, because I’ve typically done only one Pearson project at a time, I don’t bother burying it in a separate Pearson folder. Instead, the project has its own folder: ~/Dropbox/Never Enough Coffee/PSE2021 Classroom in a Book. Why navigate through a folder layer if I don’t need to?

When I’m finished with the project and move the files to my archive, I do put the PSE2021 Classroom in a Book folder in a Pearson folder that contains the other book projects I’ve done over the years.





Use a Consistent Revision Naming Scheme

So far, I haven’t said much about filenames. Some people advocate settling on a naming scheme where they rename everything, but that sounds too extreme to me. Some projects do benefit from structured filenames: If you’re collaborating with other people who are using Windows or Android systems, it’s helpful to look at a file’s name and identify where it belongs in the project. It’s the universality of the idea, that one should rename everything, that doesn’t sit well with me.

To be clear, I do impose filename order on some projects. When I’m creating screenshots for a book like this, I start with something like Screen Shot 2020-12-09 at 11.03.34 AM.png, the contents of which could be anything. I’d rename that file to org-files-naming-rename.png, with each section between hyphens indicating the chapter, sections, and action to which it belongs: the Organize Your Files chapter, the Organize Your Files and Folders section, the Use a Consistent Revision Naming Scheme subsection, and showing a file in the process of being renamed (Figure 31).


[image: Figure 31: Yes, this is a figure of me renaming the figure itself.]Figure 31: Yes, this is a figure of me renaming the figure itself.

The specific naming scheme is up to you, but keeping with one of our main themes, ensure it’s consistent.

Consistency is especially important when dealing with many revisions of the same file. Have you worked on a project or manuscript where, after a few revisions, you end up with a file named something like important-report-priority-final-final1-final2-newfinal.doc? It would be hilarious if you weren’t so frustrated knowing that the document is still probably not yet finished.

So, choose a revision naming scheme and stick to it. The pattern can be simple—the simpler the better—as long as everyone involved (even if that’s just you) imposes it consistently. The name of the file I’m working on now is Managing-Files-1.0-3-jc.rtf, which immediately tells me not just that this document is Take Control of Managing Your Files version 1.0, but that it’s the third revision completed by me, as indicated by my initials (jc). When I send the file to my editor, he will increment the revision number to 4 and add his initials.

You could do the same with a date in the filename, such as Important Secrets (2020-8-12)-jc.rtf. Just make sure everyone involved views dates in the same order; if you’re in the United States, that revision date is August 12, 2020, but if you’re in England, that date is December 8, 2020. Again: consistency.

Also keep in mind that the order in which you put elements in a filename affect how it’s sorted. So in this case, it’s easy to see which is the most recent revision, even if the list of files is sorted by name. I say this because sorting by the modification date can get confusing if an earlier file was opened and even a minor change was made; you can’t automatically trust that the latest file is at the top of the list.

Keep the scheme simple. Keep it consistent.



Use Files and Folders in iOS and iPadOS

The Files app is the built-in method of working with files and folders in iOS and iPadOS, so I’m using it as the primary example in this section. If you use a different service to sync files to mobile devices, such as Dropbox, you’ll find similar controls and concepts. (Or, add the service to the Files app and deal with all your files in one place; see Configure Locations in the Files App.)

The concept of storing files in folders in iOS and iPadOS is the same as on the Mac, but the Files app has a roundabout way of doing it. So, I’m briefly covering some basics here, with an eye toward organization.


Move Items

The Files app leans heavily on hierarchy, since there are no discrete windows and no mouse. On the iPhone especially, you can view just one level of the hierarchy at a time (Figure 32).


[image: Figure 32: On the iPhone, only one level of items is visible.]Figure 32: On the iPhone, only one level of items is visible.

Whereas in macOS you could drag an item from one window to another to move it, more steps are required on iOS and iPadOS.

In this example, I’ve misfiled a Numbers spreadsheet in the Research-RPack folder (School/Rocketeering 101/Rocket Pack Feasibility paper/Research-RPack). It should be in the Flight Tests folder two levels up (School/Rocketeering 101/Flight Tests). Here are the steps for moving it:


	To select a single file or folder, touch and hold the item you want to move until you see a pop-up menu of options appear (Figure 33).


[image: Figure 33: The easiest way to access file actions is to touch and hold an item to view a pop-up menu of options.]Figure 33: The easiest way to access file actions is to touch and hold an item to view a pop-up menu of options.

To select multiple items at once, do one of the following (which also works for single items, but is more work than bringing up the pop-up menu):


	Drag with two fingers over the items you want to select.


	Tap the item with two fingers to select it.


	In iOS, tap the More  icon, choose Select from the menu that appears, and tap the selection icon (which is really just a round checkbox) next to the item.

In iPadOS, tap Select and then tap the selection icon next to the item.





	Choose Move from the pop-up menu.

Or, with selections made, tap the Organize  icon (iOS) or tap Move (iPadOS).

(Due to the comparatively limited screen real estate on the iPhone, the Files app uses icons, while on the larger screen of the iPad it uses words.)


	On the screen that appears, navigate the hierarchy by tapping folders to disclose their contents until you reach the intended destination (Figure 34). In this example, the full path is iCloud Drive/Documents/School/Rocketeering 101/Flight Tests.


[image: Figure 34: Traipse the entire hierarchy to find the destination folder.]Figure 34: Traipse the entire hierarchy to find the destination folder.


	Tap Move at the top of the screen to relocate the file into the folder you chose.






Drag to Move a File

I mentioned earlier that you can’t just drag files from one window to another in iOS and iPadOS, but that’s not entirely true. It is possible to move a file (or folder) just by dragging, even on the iPhone, though it’s not intuitive. If you’re working in Files on an iPad, there is also a way to drag files from one folder to another, thanks to the iPadOS Split View feature.

To move a file using Split View, do the following:


	Select one or more files, and then move your finger enough that the item floats with it. (If you’re using a connected trackpad, keep the button pressed as you move.)


	Drag the item onto the Back button (or the name of the enclosing folder; either can appear) to navigate one level up in the hierarchy (Figure 35). After Back or the folder name flashes twice, the folders in that level appear.


[image: Figure 35: Drag to the navigation button to go up in the hierarchy.]Figure 35: Drag to the navigation button to go up in the hierarchy.

If the iPad is in landscape orientation, you can also walk through the folder hierarchy starting at one of the Locations you’ve specified. For example, you may want to drag to the iCloud Drive item in the sidebar, and then drill down to the folder you want from the top.


	Without lifting your finger from the screen or trackpad, move the selected file onto the folder you wish to open (Figure 36). After it flashes twice, the folder opens.


[image: Figure 36: Drag the selected file onto a different folder to open it.]Figure 36: Drag the selected file onto a different folder to open it.


	When you reach the intended destination, lift your finger from the screen or trackpad to complete the move.




On recent models of iPad and iPad Pro, you can streamline this process by opening two instances of the Files app using Split View. (Split View is available on the iPad Pro, iPad 5th generation and later, iPad Air 2 and later, and iPad mini 4 and later.) Here’s how to do it:


	Open the Files app.


	Swipe up from the bottom of the screen enough to reveal the Dock.


	Drag the Files app icon from the Dock to the left or right edge of the screen until the existing Files app window pushes aside to make room (Figure 37).


[image: Figure 37: In Split View, you can open multiple panes of the same app and move files between them.]Figure 37: In Split View, you can open multiple panes of the same app and move files between them.


	Tap a recent folder, or tap the plus  button to open another version of the same folder you started with.


	In both views, navigate so the file or folder you want to move is in one pane, and the destination is in the other.


	Drag the item to the destination pane to move it (Figure 38).





[image: Figure 38: Drag from one pane to the other to move the file.]Figure 38: Drag from one pane to the other to move the file.



Copy Items

Making a copy of a file or folder is only slightly less convoluted. To copy to another location, do the following:


	Touch and hold an item to bring up the contextual menu, or select multiple items using the two-finger touch method or the Select command as described in Move Items.


	Tap the More  icon (iOS) or More (iPadOS), and tap Copy from the pop-up menu. The file(s) are copied to the clipboard.


	Navigate to the destination folder.


	Touch and hold an empty area of the screen and choose Paste from the options that appear. A copy of the file is made there.






Mark Folders as Favorites

As you can tell from the previous pages, navigating the Files app can take a bit of work. Fortunately, you can add folders to a list of Favorites that appears in the Browse screen or the sidebar in iPadOS.

To add a folder to the Favorites list, do the following:


	Touch and hold the folder to bring up the contextual menu (Figure 39).(On the iPhone in landscape orientation, you may need to scroll the menu to reveal Favorite.)


	Tap Favorite on the menu. The item now appears in the Favorites list.


[image: Figure 39: Add a folder to the Favorites list.]Figure 39: Add a folder to the Favorites list.




Favorites are synced across your iOS and iPadOS devices. They don’t affect the Favorites in the macOS Finder window sidebar.


Note: One downside to the Favorites list is that it appears to work only with folders in iCloud Drive. Although it’s possible to add, say, a Dropbox folder to Favorites using the steps below, it’s not persistent. (If I force-quit the Files app and open it again, only iCloud Drive favorites remain.) I hope this is just a bug that will be fixed.




Save Downloaded Files

When you come across a file to download on an iPhone or iPad, you can save it to the device, iCloud Drive, or any other service that ties into the Files app. Often that’s an image, document, or PDF, but it can also include files you want to use later on your Mac, like software installers. To download and save a file, do the following:


	In an email message or on a webpage, tap the item you want to download; it typically opens as a preview, such as a PDF that you can scroll through.


	Touch and hold the download item to view options in a contextual menu. Or, if available, tap the Share  icon to bring up the menu (Figure 40).


[image: Figure 40: Save a downloaded file to the Files app, in this case from a webpage in Safari.]Figure 40: Save a downloaded file to the Files app, in this case from a webpage in Safari.


	Tap Save to Files.


	Using the hierarchical list in the share sheet that appears, navigate to a folder where the file will be saved, such as iCloud Drive/Downloads. Tap the disclosure  icon to view the contents of folders.


	Optionally tap the filename to rename it.


	Tap Save to store the file in that folder.








Organize Using Tags

Organizing files and folders, as we’ve discussed so far, imposes a spatial limit: they’re stored in a specific location, within a set hierarchy. Going back to our house analogy: you generally know where things are located due to the rooms in the house. Toiletries are kept in the bathroom, cooking utensils in the kitchen, and so forth.

But this is the digital age, and on our computers and devices, files don’t need to be kept in specific rooms. Using tags, you can quickly collect files from any corner of your Mac, and you don’t have to impose an organizational structure on them. As I mentioned in Apply Tags, a number of situations may require files to be spread out in several locations.




Tags and Sync Services




Be aware that the Files app in iOS and iPadOS recognizes tags only in files and folders in iCloud Drive. Although you can apply tags to items in other services, the tags aren’t consistently synced or visible in searches.

If your goal is to mostly work on the Mac, no problem. Or if iCloud Drive is your only (or primary) means of syncing files with your iOS and iPadOS devices, tags will work for you. But right now, tags don’t carry over to Dropbox, Google Drive, or other services I’ve tested.


Adding tags turns out to be a simple task that unlocks possibilities when you search for files and collect them using means such as smart folders.

A tag is just a word or phrase that gets attached to the metadata of a file or folder. That can be powerful, but it’s also open-ended. How many tags should you add? What terms should you use? Here are a few tips:


	Be as economical as possible. Although you can absolutely go crazy and add 20 tags to a file, it’s better to add a handful of more effective ones. Think about how you’ll organize and find the file later. Using our school project as an example, the files could all share the following tags: rocketeering101, report, school, engineering, jetpack.


	Stick to singular words consistently. You don’t want jetpack and jetpacks as separate tags, because there’s the chance you may use them on separate files belonging to the same project; when you do a search for jetpacks, the files marked with the singular jetpack won’t appear.


	I try to keep tags all lowercase for consistency. Mixed cases are accepted (the default tags like Red, Work, and Important are in title case), and fortunately the tag system won’t allow you to create instances of the same tag with different cases, like jetpack and Jetpack. However, I prefer one case as much as possible.







A Comment About the Comments Field




Speaking of metadata about files, there’s another place to stash searchable information in Finder files: the Comments field. Select any file or folder and choose File > Get Info. One of the panes within this window is Comments (you may need to click the disclosure  icon next to the name to view the field itself). Text you type here is indexed by Spotlight is considered when you Find Files in macOS.

That said, I don’t recall ever using the Comments field for anything, because it requires opening the Get Info window (or the floating Inspector window, which changes its content to reflect whichever items are selected in the Finder).


In addition to text tags, Apple provides seven color tags (by default named for their color, such as “Purple”). When you apply them to an item, they appear as a small stack of circles near the item’s name, with the most recent tag on top (Figure 41).


[image: Figure 41: Color tags appear as stacked dots (List view at left, Icon view at right).]Figure 41: Color tags appear as stacked dots (List view at left, Icon view at right).


Add Tags in macOS

In macOS, there are several locations in which to tag a file or folder (Figure 42).


[image: Figure 42: Three ways to add tags in a Finder window. Clockwise from top: the Edit Tags button on the toolbar (and its menu), the Tags field in the Preview pane, and Tags in the contextual menu.]Figure 42: Three ways to add tags in a Finder window. Clockwise from top: the Edit Tags button on the toolbar (and its menu), the Tags field in the Preview pane, and Tags in the contextual menu.

Let’s take one example:


	Select the item you want to tag in a Finder window.


	Click the Edit Tags  icon on the toolbar.


	To use an existing tag, choose it from the list that appears or the default color tags. If necessary, click Show All and then scroll the list.


	To create a new tag, type it in the field. As you type, potential matches appear. If a match isn’t found, you can create a new tag (Figure 43). Optionally, assign the tag a color by clicking one of the swatches below.


[image: Figure 43: Typing ro has found two matches, but continuing on with rocketeering101 prompts you to create a new tag.]Figure 43: Typing ro has found two matches, but continuing on with rocketeering101 prompts you to create a new tag.


	Press Return or a comma, or click the Create new tag “tag name” button to create the tag.


	Type or choose other tags in the same fashion, and then press Return to apply the tags.




The other methods of assigning tags are:


	Right-click (or Control-click) a file or folder and choose Tags from the contextual menu.


	When the Preview pane is visible in the Finder window (choose View > Show Preview to activate it), scroll down to the Tags section.


	Select the item and choose File > Get Info. The Tags field appears below the item title and icon.


	Choose File > Tags.


	In an open file, position the mouse pointer over the document’s title, and click the down arrow  to reveal its name, tags, and location.


	When saving a file in an app that supports tags, enter them in the Tags field below the filename (Figure 44).


[image: Figure 44: Add tags when you save a file.]Figure 44: Add tags when you save a file.





Edit Tags in macOS

Perhaps you’ve decided not to use a tag anymore, or you want to add tags to the list but not apply them to a particular file yet, or you accidentally misspelled a tag while you were creating it. To quickly remove an existing tag from the sidebar, delete it, rename it, or assign a color to it, right-click (or Control-click) the tag in the sidebar of a Finder window (Figure 45).

![**Figure 45:** Quickly edit a tag in the sidebar.](images/tags-edit-sidebar-menu-bordered.png){height=278.381601 width=419}

More options are available in the Finder preferences. Go to Finder > Preferences > Tags to view the list of current tags. There, you can:


	Create a new tag: Click the Add  button, type the name of the tag, and press Return (Figure 46).


	Delete a tag: Select one or more tags in the list and press the Remove  button. You can also select multiple tags, right-click (or Control-Click), and choose Delete number Tags. In the dialog that appears, click Delete Tag. If the tag was applied to any items, it’s removed from them.


	Assign a color to a tag: Click the color circle to the left of a tag’s name to change its color. Although the four default color tags are named for their colors, any tag can have its own color. For instance, you may want to color-code all work tags blue and all personal tags yellow.


[image: Figure 46: In the Finder Preferences, create new tags (left) and optionally apply colors (right).]Figure 46: In the Finder Preferences, create new tags (left) and optionally apply colors (right).


	Rename a tag: Right-click (or Control-click) a tag and choose Rename tag name from the contextual menu. Type the new name (or the correctly spelled one) and press Return.


	Reorder the sidebar list: Drag tags up or down to change the order in which they appear.


	Set favorite tags: The default color tags occupy the seven Favorite Tags spots, but only because they got there first (thanks, Apple). You can replace them with any tag you like: drag a tag to one of the slots.


	Choose which tags are visible in the sidebar: The checkboxes to the right of the tags control which tags appear in the Finder window sidebar. A tag with a checked  box shows up. A tag with an empty  box is hidden. A box with a dash  indicates a tag that was created outside the Finder Preferences list.





Tip: To make all tags visible in the sidebar, Option-click one of the checkboxes. Option-click again to hide them all.




Apply Tags Using Keyboard Shortcuts

The favorite tags, in addition to getting prime placement in the File menu and elsewhere, serve a secret purpose. Select a file and press Control-1 through Control-7 to apply the corresponding tag. If a favorite tag is applied already, pressing its shortcut key removes the tag. Or, to remove all tags from a file, press Control-0 (zero).

That’s helpful for that elite set of tags, but what about the rest? The one thing missing from the previous options is a way to quickly apply or create tags using a keyboard shortcut. However, the keyboard shortcuts settings in macOS makes it possible. Here’s how to set up a shortcut that opens the tags interface in the Finder:


	Open System Preferences > Keyboard.


	Select App Shortcuts in the left pane.


	Click the Add  button.


	In the Application pop-up menu, choose Finder.app.


	In the Menu Title field, type Tags… (exactly as it appears in the File menu, with the three periods).


	In the Keyboard Shortcut field, press a collection of keys to invoke the command, such as ⌘-Option-Shift-T (Figure 47).


[image: Figure 47: Create a keyboard shortcut to quickly add tags.]Figure 47: Create a keyboard shortcut to quickly add tags.


	Click the Add button.


	Lastly, you need to relaunch the Finder: hold the Option key and right-click (or Control-click) the Finder icon in the Dock. Choose Relaunch.




Now, when you select a file or folder, you can press the shortcut key combination to bring up the Tags input field.




Add Tags in iOS and iPadOS

The tags system in iOS and iPadOS isn’t as robust as the implementation in macOS, but there’s enough connective tissue to make tags useful.


Note: Keep in mind that tags work well only with files and folders in iCloud Drive. See Tags and Sync Services.



Create or Apply Tags in iOS and iPadOS

As with a lot of actions in the Files app, working with tags is similar to the Finder, but with a different look. To create or apply a tag, do the following:


	In the Files app, or the Files browser in a compatible app such as Pages, locate the file or folder you want to tag.


	Touch and hold the item until the contextual menu appears (Figure 48).


[image: Figure 48: Create and apply a new tag in iOS.]Figure 48: Create and apply a new tag in iOS.


	Choose Tags from the menu.


	In the Tags list, tap one or more tags to apply them. Or, tap Add New Tag to create one.


	In the Add New Tag screen, type the name of the tag and optionally assign a color by tapping one of the colors below. Tap Done or Return on the onscreen keyboard to create the tag and apply it.


	Tap Done to exit the Tags screen.




Another option is to choose Info from the contextual menu, scroll down to the Tags field, and tap Add Tags to access the steps above (Figure 49).

![**Figure 49:** The Info sheet includes an area for adding tags.](images/tags-ipad-info-c-bordered.png){height=293.449465 width=419}



Edit Tags in iOS and iPadOS

What happens on iOS or iPadOS when you misspell a tag when you create it? It may sound like I’m harping on this topic, and I am, thanks to personal experience. To edit the list of tags, do the following:


	In the Files app, go to the Browse screen (iPhone) or view the Files sidebar (iPad).


	Tap the More  icon and choose Edit (iPhone) or Edit Sidebar (iPad).


	Scroll to the Tags section (Figure 50), where you can:


	To remove a tag, tap the Delete  icon followed by the Delete button that appears. (You can also swipe the tag to the left to reveal the Delete button without editing the list.)


	Tap the tag’s text to edit its name.


	Drag the Move  icon to reorder the tags in the list.





[image: Figure 50: Editing the Tags list on an iPhone.]Figure 50: Editing the Tags list on an iPhone.


	Tap Done at the top of the screen to exit the edit mode.








Automate File Organization

The problem with “file management” is that the term is disingenuous. We think of competent managers as people who know how to marshall their employees and resources to get a job done, often in a quick manner. But file management too often means, “I’m going to end up doing all of it, especially the boring, repetitive parts.”

Using automation can save steps or even handle a lot of menial tasks in the background. By way of example, I’m going to show a way to quickly create a template of nested folders in macOS you can use when you start a new project, and then introduce you to Hazel, a utility that is pretty much that competent manager I mentioned.


Create Folder Templates

Earlier in Set Up Consistent Folder Structures, I suggested creating a set of default folders you could use as a template for new projects. One way to do that is to keep some empty folders around and duplicate those, but then you have empties taking up visual space.

Here’s a way to easily make an Automator Quick Action that creates a project folder and nested folders for assets:


	Open the Automator app and choose File > New.


	Select the Quick Action type and click Choose.


	From the Library list in the sidebar, drag the Run AppleScript action to the work area at right.


	Set the first set of pop-up menus at the top of the work area to “Workflow receives current [folders] in [Finder.app].”


	In the Run AppleScript action, paste the following script:

 on run {input, parameters}

 try
     tell application "Finder" to set FOLDER0 to (folder of the front window as alias)
 end try
 tell application "Finder"
     set folder1 to make new folder at FOLDER0 with properties {name:"PROJECT"}
     set folder2 to make new folder at folder1 with properties {name:"Correspondence-"}
     set folder3 to make new folder at folder1 with properties {name:"Images-"}
     set folder4 to make new folder at folder1 with properties {name:"Research-"}
     set folder5 to make new folder at folder1 with properties {name:"Videos-"}
 end tell

     return input
 end run

The script should now look like Figure 51.


[image: Figure 51: We’re setting up this script in Automator in order to easily run it as a Quick Action in the Finder.]Figure 51: We’re setting up this script in Automator in order to easily run it as a Quick Action in the Finder.


	Choose File > Save and name the Quick Action New Project Folders. Click Save.




In this script, the second tell command creates a folder (folder1) in the window called PROJECT. The next folders are called sequentially (folder2, folder3, etc.), but they’re all created within folder1. You can customize the script to create folders with your own names by changing the text between the quotes in {name:"folder name"}, and by deleting or adding other folders in the sequence.

To run the Quick Action, do the following:


	Open a Finder window where you want the new folders to appear.


	Right-click (or Control-click) any existing folder (such as another project folder, in our example) and choose Quick Actions > New Project Folders. The nested folders are created (Figure 52).


	Rename the new folders to reflect the name of the project.


[image: Figure 52: In one step, a new project folder hierarchy is created.]Figure 52: In one step, a new project folder hierarchy is created.






Automate with Hazel

The Automator app in macOS includes the capability to create AppleScript Folder Actions, which are scripted behaviors that run when a file is added to a specific folder. A simple example would be an action that takes any file in that folder and moves it to a different location; or, it could first add your initials and the date to the end of the filename before moving the file (see Use a Consistent Revision Naming Scheme).

It’s a powerful tool, but for my money—and I was happy to pay the $42 price—Noodlesoft’s Hazel is a better option, especially if you’re not interested in scripting or building Automator actions.


Tip: If you do want to build your own automations, get Joe Kissell’s book Take Control of Automating Your Mac. In fact, even if you do plan to purchase Hazel, get Joe’s book first, because in the back is a coupon to get 20% off Hazel’s price. Joe knows what he’s talking about—he even wrote Hazel’s built-in help.


Hazel watches folders and takes action based on rules you set up. The app includes several starter rules, such as one that applies the Red tag to items that have been sitting in a folder longer than four weeks. It can automatically delete files that have been sitting in the Trash for a period of time, or keep the Trash size below a set storage limit.

Let’s go back to the example of using a folder hierarchy for utility bills (see Folders Example 2: Personal Files). Before Hazel, I would download the latest statement as a PDF, rename the file to something intelligible, navigate to my set of home utilities folders, and move the file there. I typically don’t even open the statements, since they’re either paid automatically from my bank account, or I see the relevant information when I connect and pay the bill. I still want copies of the statements for my files, but because the process was mind-numbing, I wasn’t motivated to do it.

Now, I do…nothing beyond download the files. Hazel handles the rest in the background using the following rule:

If [all] of the following conditions are met

 [contents] [contain] 200XXX67123456 (the account number)

Do the following to the matched file or folder:

 [Move] to folder [Puget Sound Energy]

 [Rename] with pattern: PSE_[date created] [extension]

 [Add tags] statement utility pugetsoundenergy

Here’s what the rule is doing; Figure 53 shows the rule in its Hazel window:


	The rule is attached to the Downloads folder, which is my default destination for files downloaded from Safari.


	It looks inside the file for my account number, a unique identifier that would only appear in a bill from that company.


	If the rule matches both of those conditions, Hazel moves the file to my House/Utilities/Gas Company folder. (That folder is located in a Dropbox folder shared with my wife, so the statement is also copied to her computer.)


	Lastly, the rule renames the file as PSE_date created.extension (from the oh-so-helpful default of ViewFullPdfBill.pdf that the gas company assigns), resulting in a file such as PSE_2020-12-10.pdf.


[image: Figure 53: Hazel automatically files my monthly household gas statements using this rule.]Figure 53: Hazel automatically files my monthly household gas statements using this rule.




Another example is a rule I’ve set up archives podcast recordings older than 4 weeks to the NAS drive on my network.




Use Information Management Apps

Most of this book is about what you can do using the frameworks Apple provides; it’s their operating systems and cloud pathways for syncing files and folders between devices. Managing files overlaps with managing other sorts of data, like text snippets, ideas, and lists. Some third-party applications excel at that sort of thing, so I want to briefly mention a couple.

When I first decided to go paperless—scanning physical files and storing digital copies that I could more effectively store and search—I started using Yojimbo, from Bare Bones Software. Important documents, scanned and online receipts, and miscellaneous files go into my Yojimbo library (Figure 54). Every item is tagged, and the app is quick to index the contents of every readable PDF, making for swift searching.


[image: Figure 54: I know that when I turn to Yojimbo, I can find the document or snippet I need.]Figure 54: I know that when I turn to Yojimbo, I can find the document or snippet I need.

Another popular option is DEVONthink, which sports similar features and is the subject of the free Take Control of DEVONthink 3 book by Joe Kissell.

These apps have advantages over managing everything in the Finder:


	Dedicated apps provide a central location for your important files—think tax forms, automobile records, legal correspondence, and similar documents. Yes, you can put all those things in folders in the Finder (which is still a valid way of organizing those items). However, they’re also competing in the Spotlight index with absolutely everything else stored on your computer. As a result, dedicated apps tend to be faster and more focused on retrieving your information.


	Some apps feature the capability to encrypt the database or sensitive individual items, a task that’s more complicated in the Finder.


	DEVONthink especially is an example of an app with a better capability to intermingle smaller snippets of information, such as notes, ideas, software license codes, and the like.


	The traditional dynamic between Apple and independent developers applies in this category, too: Apple is often content to provide basic functionality, and may get around to improving pieces over time if it sees enough interest. (Have you used the Contacts app lately? Case closed.) Although third-party developers are also reliant on Apple technologies, they’re generally more motivated and swifter to act than Apple.








Find Your Files

When we think of file management, it’s usually focused on the front end of dealing with files: organizing how and where they’re stored, adding metadata like tags to better identify them, and setting up ways to make the process easier. Once a file has been handled, we move on to the next, and then to the next.

That work is all to service the other side of file management: finding those files later, whether that means knowing immediately which directory to open or using search tools to get software to do the work for you.


Find Files in macOS

Apple’s Spotlight search technology is woven throughout macOS, collecting results from your web browsing history, contacts, calendar events, and several other sources. For our purposes, of course, I’m focusing on locating files and folders in the Finder.


Filter Files by Tag

I’m getting this one out of the way early because it’s quick and easy. Expand the Tags list in the sidebar of a Finder window and select a tag to view only files marked with that tag. You can select only one tag at a time, though, so if you need a more complicated search, keep reading.



Perform Spotlight Searches

Most often, you’ll probably want to bring up the Spotlight window, which can be invoked in any app, not just the Finder. It’s a good first step, and you can refine the search if needed. To perform a general Spotlight search, do the following:


	Click the Spotlight  icon in the menu bar, or press ⌘-Space, to bring up the Spotlight window (Figure 55).


[image: Figure 55: The Spotlight Search bar is a fine place to begin.]Figure 55: The Spotlight Search bar is a fine place to begin.


	Type anything in the field; results appear as you type, even filling in words that macOS thinks you might be looking for based on recent items (Figure 56).


[image: Figure 56: I’ve typed only “rocket” so far, but Spotlight has suggested the Rocketeering 101 folder as the top pick because it has been recently modified.]Figure 56: I’ve typed only “rocket” so far, but Spotlight has suggested the Rocketeering 101 folder as the top pick because it has been recently modified.


	Use the arrow keys or single-click other items in the list to select them, or scroll to view more.


	With a selection made, press Return or double-click the item to open it and exit the search bar.


Tip: Press the Tab key to display a preview of the selected item in the search results window. Hold the ⌘ key to see the item’s path at the bottom of the preview (Figure 57).



[image: Figure 57: Pressing the Tab key gives you a preview while still in the floating Spotlight Search window.]Figure 57: Pressing the Tab key gives you a preview while still in the floating Spotlight Search window.




If you want to refine the results, scroll to the bottom of the list and choose Search in Finder, where you can apply additional criteria.




What Else Can a Spotlight Search Do?




The Spotlight Search bar can also perform some nifty actions, such as converting numbers, doing mathematical calculations, looking up the definition of a word, and launching apps.

To give you an idea, press ⌘-Space and type 6.25m. It assumes you mean “6.25 meters,” and displays 6.25m = 6.84 yards. Press the Tab key to view other conversions, such as 246.06 inches. You can convert weights and volumes (3 tbsp = 9 teaspoons), temperature (46F = 7.78 °C), currency (27 euros = 32.72 US dollars), and more.

When you need to make a quick calculation, just type it into the field, such as 674*37, and see that the answer is 24,938.



Search in the Finder

The Spotlight window is the quickest way to perform a search for a wide range of items, but when you’re specifically looking for files and folders, it’s best done using the Spotlight field in a Finder window:


	Open a new Finder window.


	Click the Spotlight  icon in the window’s toolbar, or press ⌘-Option-F to activate the Search field.


	Start typing a search term into the field. The window displays matches as you type (Figure 58). Put words that belong together in quotes, as in "rocket booster".


[image: Figure 58: Possible matches appear in the window as you type. In this case, the query has found 324 items that include “rocket” in the filename or in the contents of the files. (If you don’t see the item count, choose View > Show Status Bar.)]Figure 58: Possible matches appear in the window as you type. In this case, the query has found 324 items that include “rocket” in the filename or in the contents of the files. (If you don’t see the item count, choose View > Show Status Bar.)





Note: When you perform a search in a Finder window, think of the previous contents as waiting patiently under the search interface. When you end the search by clicking the Cancel  icon, the previous window contents reappear.


The advantage of searching in a Finder window versus the Spotlight window is the additional controls available to direct your query. In Figure 58, you can see the option in the pop-up menu to narrow the search to files with “rocket” in the filenames or to show only files marked with the “rocketeering101” tag, plus the option to search This Mac (the entire computer) or just the contents of the window in which you began the search, in this case my home folder “jeffcarlson.”


Tip: You can set the default location for Finder window searches. Go to Finder > Preferences > Advanced and choose an option from the “When performing a search” pop-up menu: Search This Mac, Search the Current Folder, or Use the Previous Search Scope.




Use Modifiers in the Search Field

There are two ways to boost the effectiveness of a Spotlight search: using text modifiers when typing the search term, and defining additional criteria using a series of pop-up menus. The first option is the quickest to implement because you’re already typing, though you have to know what to enter; the second option involves more work, but can dig further into the nooks of your files and folders to find results.

In the Search field (and also in the Spotlight window), type not just the term you’re looking for, but information about the term. For instance, the term “rocket” alone brings up hundreds of files on my Mac that either include “rocket” in their filename, contents, tags, or other metadata.

But let’s say we want only image files related to rockets. For that, we’d type rocket kind:image. The results include images from our imaginary school project and a few others, for a total of 10 files (Figure 59).

![**Figure 59:** By typing a few more characters, I’ve narrowed the results to include only images relating to “rocket.”](images/find-spotlight-modifier-kind2-bordered.png){height=216.762667 width=419}

Although we can see the files we want in this list, suppose we want to narrow it to files created in December. We’d type rocket kind:image created:>=12/1/20, which is shorthand for “files containing the word ‘rocket,’ which are image files, and created on or after December 1, 2020” (Figure 60). (Note that there are no spaces within each attribute; spaces are used only to separate them.)

![**Figure 60:** Now we see only the four image files containing “rocket” and created in December 2020.](images/find-spotlight-modifier-createddate-bordered-c.png){height=185.198 width=419}

The Search field also understands the Boolean operators AND, OR, and NOT. Instead of Spotlight trying to find files that match every condition in the field, the operators give you power to exclude or offer alternatives. For example, imagine we want to find every file that matches “rocket,” but we don’t need any of the image files for this search. We’d write rocket NOT kind:image (Figure 61).

![**Figure 61:** Adding <code>NOT</code> removes image files from the results.](images/find-spotlight-modifier-bool-not-bordered-c.png){height=161.454667 width=419}


Tip: The capitalization of the Boolean operator is important, as it signals Spotlight to treat it different from regular words.


For another example, "rocket booster" AND jetpack NOT kind:image reveals files with both the terms “rocket booster” and “jetpack,” but which are not images. You can substitute a minus sign (hyphen) for NOT, as in "rocket booster" AND jetpack -kind:image.



Add Search Criteria

Boolean operators and modifiers are certainly convenient. However, this approach annoys me somewhat because you need to have these descriptors in your head already. (To be fair, in most cases you can make educated guesses and hit the mark, such as kind:pdf or modified:<12/9/20.)

That’s why the capability to define all sorts of search criteria in a Finder window is so powerful. You can find items using sets of criteria in fields and menus, laid out in front of you, so you don’t have to shake your memory for the correct terminology. Here’s how to access these controls:


	After you initiate a search, click the Add  button at the right side of the window below the search field, which adds a new criterion to the top of the window.


	From the first pop-up menu, choose which attribute to search, such as Name, Tags, or Kind.


	The context of the attribute determines the next options. For instance, the default options for [Last modified date] look for matches within the last number of days (Figure 62). You can change the scope using the pop-up menus and number field to read [Last modified date] [is after] a specific date.


[image: Figure 62: Choose several date ranges to filter the results.]Figure 62: Choose several date ranges to filter the results.


	To add more criteria, click the Add  button for the item you just created; the new criterion appears below it.




The search results update as you specify criteria.

Where this approach gets really interesting is in the wide variety of attributes you can search for. Click the Add  button and choose Other from the first pop-up menu. That displays a dialog containing hundreds of other criteria (Figure 63).


[image: Figure 63: Search files based on hundreds of criteria.]Figure 63: Search files based on hundreds of criteria.

For example, if you wanted to find placeholder images in your project in order to replace them with better quality ones, you could add the attribute [Pixel width] and set it to [is less than] 1000.

If you find yourself using one of these “other” attributes frequently, select the In Menu checkbox to add it to the first pop-up menu that appears when you add a new criterion.

Lastly, we come to Spotlight’s secret weapon in Finder window searches. I mentioned earlier that you can use the Boolean operators AND, OR, and NOT when doing a text search. You can do the same in the criteria menus.

The way the menus are constructed, the criteria fall under the “all” umbrella, where a file must match every item to show up in the search. For example, Spotlight would find files that include the word “rocket,” and were modified after 12/1/2020, and include the tag “jetpack.” If just one of those three attributes don’t apply, a file doesn’t appear in the results.

But what if you’re working on two rocket projects, one for school and one for your personal use? The query above would collect files for both projects. Using the Boolean option, you can make the query selective:


	Hold Option and click the More  button that appears in place of the Add  button. A pair of criteria are added: the Boolean operator on one line, and a regular criterion on a second, indented line.


	Set an operator from the first item: Any, All, or None (which correspond to OR, AND, and NOT).


	Set the attribute for the second item.

For our example, we’d set the Boolean operator to None, and the attribute to [Tags] [matches] rocketeering101 (the class name) (Figure 64).


[image: Figure 64: By omitting the “rocketeering101” tag with a Boolean operator of None, the files for this amazing—explosive, I dare say—business idea is kept separate from the jetpack school work.]Figure 64: By omitting the “rocketeering101” tag with a Boolean operator of None, the files for this amazing—explosive, I dare say—business idea is kept separate from the jetpack school work.







Cut the Spotlight Clutter




A spotlight is supposed to shine a narrow band of light on something to be highlighted, but over time Spotlight has become more of a floodlight. When you perform a Spotlight search, you get results that include events, theatrical movies, music artists, and Siri suggestions.

Here’s how to be more choosy about what ends up in the results list. Go to Apple  > System Preferences > Spotlight and make changes on the following two tabs:


	Search Results: Deselect the checkbox for any categories you want to remove from search results, such as Bookmarks & History.


	Privacy: Spotlight builds an index of your internal storage and any connected drives. To prevent it from indexing a location, click the Add  button and choose a folder or volume Spotlight should skip. Or, drag the item into the privacy list. If you have a cloned drive attached to your computer for duplicate backups, you may want to add that to the list and avoid duplicate results in different locations.








Create Smart Folders for Frequent Searches

Building an elaborate search in the Finder seems like a lot of work each time you want to find something, but that effort doesn’t have to be tossed once you get the results. You can save the entire query as a smart folder, or create a smart folder from scratch, that performs the search whenever you load the folder. (If you’re familiar with smart albums in the Photos app or smart playlists in the Music or iTunes apps, it’s the same concept.)

Using the example in Figure 64, where you have two separate but similar projects, it’s inevitable that more files will be added that fit the same criteria. Saving that search as a smart folder gives you the ease of opening a folder to reveal the files, instead of re-running the search, and the knowledge that the contents will be automatically updated to reflect any new or changed files that fit the criteria.

If you’ve decided to Organize Using Tags, or chosen to integrate tags more into your organizational system, smart folders really make that decision pay off. In the sidebar of Finder windows, you can select a tag in the Tags list, but only one tag at a time. A smart folder lets you save queries that include multiple tags.


Create a Smart Folder

There are two ways to create a smart folder: start one from scratch, or save the criteria from a current search. For the former, in the Finder choose File > New Smart Folder and add criteria as you did above in Add Search Criteria. In both cases, follow the next steps to save the search as a smart folder:


	Click the Save button below the search field.


	In the dialog that appears, give the smart folder (which has the filename extension .savedSearch if you’ve have all filenames visible) a unique name (Figure 65).


[image: Figure 65: Save the search query as a smart folder.]Figure 65: Save the search query as a smart folder.


	Select the Add To Sidebar option to include the smart folder in the list of favorites for quick access.


	Optionally choose a location for the smart folder (especially if you choose not to add it to the sidebar). The default location for them is ~/Library/Saved Searches/, which isn’t normally accessible to browsing (see the sidebar just ahead, Reveal the Hidden Library Folder).


	Click Save.





Note: If you’ve enabled syncing the Desktop and Documents folders in iCloud Drive (see Sync the macOS Desktop and Documents with iCloud), smart folders appear in the iCloud section of the sidebar.


To access the smart folder later, select it in the sidebar (if you saved it there), or open it as you would any other folder in the Finder, such as by double-clicking it. Smart folders appear colored purple with a gear icon to differentiate them from other folders (Figure 66).


[image: Figure 66: I’ve saved this smart folder to the desktop. It also appears in the sidebar because I selected Add To Sidebar when creating it.]Figure 66: I’ve saved this smart folder to the desktop. It also appears in the sidebar because I selected Add To Sidebar when creating it.




Reveal the Hidden Library Folder




macOS and apps store a lot of important information in your ~/Library folder—often stuff you don’t need to touch, but occasionally want to access (like smart folders). If you open your home folder, however, you probably don’t see a Library folder.

Precisely because apps use this folder as a place to store preferences and other files, Apple discourages folks from poking around inside (that’s also why the System folder is now read-only). It can be helpful to get into the ~/Library folder, though, so there are two ways to do it:


	Hold Option and choose Go > Library, which is visible only when with the Option key modifier.


	With a new Finder window active, choose Go > Home. Then choose View > Show View Options and select the Show Library Folder checkbox.




If you do keep it visible, just promise not to start throwing away random files.




Edit an Existing Smart Folder

A smart folder is endlessly malleable, so if you want to add or remove search criteria, you can do it easily. Here’s how:


	Open a smart folder to view its results.


	Click the Action  icon and choose Show Search Criteria.


	Change the criteria as needed to update the search results.


	Click the Save button.




To remove a smart folder you’re no longer using from the sidebar of Finder windows, right-click (or Control-click) it and choose Remove from Sidebar, or drag it out of the window until the Remove  icon appears on the pointer.

The smart album itself is still available where you saved it. If you want to delete it entirely, do the following:


	Locate the smart folder in the Finder. If it’s in the Finder window sidebar, right-click it and choose Show Enclosing Folder. Or, if it was saved in the default location, go to ~/Library/Saved Searches.


	Drag the smart folder to the Trash, or select it and choose File > Move to Trash.




Because a smart folder is just a search query, none of the actual files and folders that appear in it are sent to the Trash.




Perform a Siri Search

Even when I’m working alone in my office, I’m not inclined to ask Siri to search for files for me. Plus, the accuracy depends entirely on how well Siri understands the request. That said, if you’re more chatty than I am, you may find it useful. To search for files using Siri, do this:


	Click the Siri  app in the Dock, the Siri  icon in the menubar, or say, “Hey Siri” (although the latter may be picked up instead by an iPhone or other Apple device nearby). If you own a MacBook Pro with a Touch Bar, touch the Siri  icon there.


	Speak your search phrase, such as “Show me all image files tagged with rocket.” The text is dictated in the Siri window.


	Sometimes Siri will start the search when you stop speaking; more often, I find that I need to press the Siri  icon again, click the active Siri icon in the Siri window, or press the Esc key, to complete the query. If results are found, they appear in the window (Figure 67).


[image: Figure 67: Invoking Siri brings up the familiar listening window (left). In the results window (right), you can see at the top where it initially didn’t transcribe my request correctly.]Figure 67: Invoking Siri brings up the familiar listening window (left). In the results window (right), you can see at the top where it initially didn’t transcribe my request correctly.


	Click one of the results to open a specific file or folder, or choose “Show all number results in Finder” to view them in one window. (As of Big Sur 11.1, this should work, but it appears to be buggy.)







Spotlight Problems? Rebuild the Index




Spotlight’s search is based on an index of everything it finds on your Mac, from file names and tags to contents. If results aren’t coming up as you expect, there’s a last-ditch solution: rebuild the index. To do so, follow these steps:


	Go to Apple  > System Preferences > Spotlight > Privacy.


	Click the Add  button and choose the volume or folder that’s giving you trouble to the Privacy list.


	Select that item in the list and click the Remove  button.


	Quit System Preferences.




Spotlight rebuilds its index in the background, which takes a while.




Go Beyond Spotlight with Search Utilities

Spotlight can be a powerful tool. In Apple fashion, however, a lot of it is hidden to make it less intimidating for most people. And, to be honest, sometimes Spotlight just doesn’t work well, in which case it’s worth looking at a few utilities that buttress or replace Spotlight.


HoudahSpot

HoudahSpot taps into the Spotlight index with an interface that presents several search criteria up front. It’s also often faster than standard Spotlight searches.

A few other things stand out with HoudahSpot:


	It can search multiple locations at once, such as your home folder and a mounted network drive, in the same query. Additionally, you can exclude specific locations. For example, suppose you want to search your local volume and a mounted NAS volume, but not a big “Temp Storage” folder there.


	HoudahSpot can search your Apple Mail messages just as easily, since Spotlight also indexes those.


	Several search templates are included, and you can save your own searches (much like creating smart folders in the Finder). The Misplaced Music Files search, for instance, looks for any audio file longer than 30 seconds that isn’t in your Music or iTunes library (Figure 68). Another template, Long Lost Files, looks for files that haven’t been opened or used within the last five years. And, of course, you can edit the templates and create your own.


[image: Figure 68: A HoudahSpot pre-made template finds those audio files you may have downloaded but not added to your Music library.]Figure 68: A HoudahSpot pre-made template finds those audio files you may have downloaded but not added to your Music library.





Tip: If you’re looking for a search utility that’s the opposite of HoudahSpot in terms of simplicity, check out Houdah’s Tembo. It’s the same underlying technology, but with a friendlier interface.




Path Finder

Path Finder has been around since long before the Finder was remotely as capable as it is now. It offers a multi-pane experience that feels a bit like being in the cockpit of an airplane. In addition to browsing folders, you can activate modules for tagging, running Terminal commands, checking file permissions, and lots of other geeky file-related things (Figure 69).


[image: Figure 69: Path Finder wants you to forget the macOS Finder exists. In fact, a preference exists to quit the Finder entirely when Path Finder is running.]Figure 69: Path Finder wants you to forget the macOS Finder exists. In fact, a preference exists to quit the Finder entirely when Path Finder is running.

The search capabilities are similar to the Finder’s, looking for Spotlight criteria and being able to save searches for later. You can also perform a “low-level search” that doesn’t use the Spotlight index and focuses on file attributes like dates, size, and other criteria.





Find Files in iOS and iPadOS

The iOS and iPadOS implementation of Spotlight isn’t as broad as in macOS, but the basics are there. You can start searches on the home screen, or jump into the Files app, which has more options.


Search Using Spotlight

To invoke a Spotlight search on the home screen in an iPhone or iPad, do the following:


	Swipe down to reveal the search field, or swipe right to view widgets and then tap to activate the search field (Figure 70).


	Type or dictate your query into the field.


	Depending on what comes up in the results, tap the file or folder you want. Or, tap Search in App for the Files app to continue the search there.


[image: Figure 70: Swipe down on the home screen to start a search (left), which you can continue in the Files app (right).]Figure 70: Swipe down on the home screen to start a search (left), which you can continue in the Files app (right).





Note: Unlike in macOS, attempting to search for files or folders using Siri in iOS or iPadOS brings up only things like web results for the terms you dictate.




Search in the Files App

The search capability in the Files app is similarly limited compared to macOS, but it does have a glimmer of extra functionality. Type a term into the search field to find potential matches. You also have a few other options:


	If any tags match what you’re typing, they appear below the search field. Tap one to restrict the search to files and folders with those tags.


	To specify a kind of file, type that term and choose an option that appears below the search field. For example, to restrict the search to just images, type images and choose Images (Figure 71). Criteria that are not just text matches appear with icons. When you tap one, it appears in the search field in a box.


[image: Figure 71: Here I’ve restricted the search to images (left), and then added more parameters to narrow the results (right).]Figure 71: Here I’ve restricted the search to images (left), and then added more parameters to narrow the results (right).

For another example, type doc into the field and you’ll see several document types of documents that iOS recognizes, such as “PDF document” and “Pages Document,” to choose from.


	Some time-based searches are possible. Type yesterday or december or a date like 12/1/19 and choose the option that pops up (the latter shows “Tuesday, December 1, 2019”). You can also type last number days and specify a number such as 15 to view items created or modified within the last 15 days, or after 11/1 to find items after November 1 of the current year.





Tip: On an iPad, you can also choose whether the search applies to items in the Recents view or the service selected in the Locations list in the sidebar. However, the “current location” works only with iCloud Drive; if another service is selected, no results are shown.


To act on a search result, tap an item to open it, or touch and hold to display the contextual menu with options.






Clean Up Your Files

When you clean up old paper files, you’re at the mercy of the physical world. Maybe you (or whomever had the files before you) had the prescience to store related files in clearly marked boxes, or perhaps files are completely haphazard. Either way, you must open a box, open each folder, and handle each file.

With digital files, you’re not limited to pushing atoms around a space. There’s still clutter and stuff to sort through, but you can use the tools and techniques we’ve covered so far to make quicker work of it.


Set a Cleaning Strategy

Establishing a good file management strategy is primarily about looking forward: how you act on files you will create or receive. As time goes by, that structure makes it easier to locate those files later.

What about the files that existed before you adopted your strategy? They may be organized in similar schemes, or they might be in a condition best described as “a tornado ripped through the filing room.” Either way, you can apply the techniques we’ve covered to your old files, remove what you don’t need, and generally get to a state that’s good for your files and your mental health.


Start Easy

In my book Take Control of Your Digital Photos, one of the struggles I describe is finding the time to work through the backlog of unsorted photos. It’s so easy to say to yourself, “This weekend I’m going to sit down and organize all my old photos!” And then something comes up, or the task is much larger than you expected, or you don’t make much progress, and the goal is abandoned.

Dealing with all your files is the same way. Break the job into smaller tasks that are more manageable. At the beginning of this book, I encouraged you to ask yourself, What Is the Scope of the File Management? Now, consider the scope of the existing files that need organization. Some possible strategies could include:


	Choose a handful of folders to sort through. Not your entire Documents folder or that nested series of Old_Documents/Old_Stuff/To_File folders you may have been stashing files in for years. When you finish with your small selection, go enjoy the beverage of your choice and then choose another handful of folders. (Or don’t! Take the rest of the day off.)


	Use search queries and smart folders to locate groups of similar files, which may share keywords or tags. Locate projects or clients or school assignments and scan through them.


	Work backward through your archive by date. Set up smart folders to show all the files created in 2017, for example, or in the last half of 2017.


	If you have files with the same identifying information, such as old utility bills, duplicate the rules you created in Automate with Hazel that are currently watching for new files in the Downloads folder and point them at your old files.


	Take advantage of existing folder hierarchies and adapt them to your current system. Maybe you already have folders for bills and bank statements, but they’re in separate locations.


	If all the older files are thrown together haphazardly, maybe you keep them in place but assign tags to them, saving you the trouble of moving files into other folder hierarchies.


	Find and Eliminate Duplicates to cut down the amount of clutter overall.


	Free Up Storage Space, which is often a quick way to delete large unnecessary files or folders and give you the satisfaction of recovering large amounts of storage space.




Most of all, remember that cleaning up files does take time. You will run into situations where you’ll need to dig into folders of files to determine what can be deleted or filed, just as if you were going through those cardboard boxes of paper files.



Clean with Spotlight and Smart Folders

When faced with a mass of files and folders, you want to break them down into more manageable piles. One way of doing that is to locate files you haven’t touched recently by searching in Spotlight by date.

Let’s say you want to use the year 2018 as a starting point. Start a new Spotlight search (choose File > Find) and set the following criteria using what we learned in Search in the Finder:

[Last opened date] is [after] 1/1/2018

[Last opened date] is [before] 12/31/2018

However, that search brings up too much. In Figure 72, I’m seeing catalog files and backups for an old version of Luminar, a photo editing application, on my Mac.


[image: Figure 72: Searching only by date displays too many items that don’t help me here.]Figure 72: Searching only by date displays too many items that don’t help me here.

When I select an item, I see its path at the bottom of the window. That could help me start to sift through that location for files that need to be archived or deleted, but in this case I want a better pointer. So, next I’ll narrow the search to include only folders last opened in 2018 by adding the following criterion:

[Kind] is [Folder]

This result is much easier to handle (Figure 73). I can right-click (or Control-click) an item and choose Show in Enclosing Folder, and then deal with the folder and its contents by moving, deleting, or tagging them.


[image: Figure 73: Turns out I have only two folders that were last opened in 2018 on my Mac.]Figure 73: Turns out I have only two folders that were last opened in 2018 on my Mac.

Alternatively, I could add tags to items in the search window, such as a movelater tag set to yellow for easy identification later.

If you use Hazel, the built-in Old Items rule does a variation of this search. All you’d have to do is specify a new folder, Duplicate the Old Items rule, and assign the duplicate to the new folder.



Find and Eliminate Duplicates

Another annoyance with files over time is that they seem to spawn duplicates. Apps dedicated to dealing with them are available, like Gemini 2 (just ahead), but handling them still requires that you evaluate what the software thinks is a duplicate and take action.

Here’s a simple way to search for duplicates using Spotlight:


	Navigate to a folder you want to check and choose File > Find to create a new search.


	Leave the first default criterion at its default, which is:




    [Kind] is [Any]


	Hold Option and click the More  button that appears in place of the Add  button. Set the condition to the following to remove folders from the results:



    [None] of the following are true

    <code>[Kind] is [Folder]</code>


	Click the Group By  icon on the toolbar and choose Kind.


	Option-click the Group By  icon and choose Name to sort the items by name.




Now, the files of the same name and kind appear next to each other in the list (Figure 74). Select one to reveal its path at the bottom of the window and decide whether to keep it or not.


[image: Figure 74: I forgot I had duplicated this Automator app in several places for convenience while working on different projects.]Figure 74: I forgot I had duplicated this Automator app in several places for convenience while working on different projects.

Granted, that’s a fairly laborious approach. The app Gemini 2 by MacPaw in macOS does a much better job of finding and presenting duplicates in a way that’s easier to determine where files are located (Figure 75). You can also mark duplicates for removal, and then throw them all in the Trash at once when you’re ready.


[image: Figure 75: Gemini finds exact duplicates plus possible matches.]Figure 75: Gemini finds exact duplicates plus possible matches.


Tip: MacPaw also sells an app called Gemini Photos for iOS and iPadOS, which applies its duplication-finding technology to your Photos library.





Free Up Storage Space

This book is mostly focused on helping you with the contents of your files, but storage space is always a part of that. Plus, it can be extremely satisfying to dump gigabytes of large files or junk that were taking up space.

For this task, I turn to third-party software. DaisyDisk scans the drive you choose and presents a visual graph of large files, with the option to delete them straightaway (Figure 76).


[image: Figure 76: Locate and remove large files and folders using the DaisyDisk app.]Figure 76: Locate and remove large files and folders using the DaisyDisk app.


Tip: If you need to free up storage space in a hurry, DaisyDisk can also help you remove invisible snapshot files that macOS creates. I discuss snapshots and more in Take Control of Your Digital Storage.


If you’re not as impressed with the graphics as I am, macOS also includes a feature for identifying large files and taking other action on the computer’s storage. Choose  > About This Mac > Storage and click Manage to view categories of storage being used (Figure 77).


[image: Figure 77: Apple’s storage management options reveal more categories of files.]Figure 77: Apple’s storage management options reveal more categories of files.

The tool also lets you browse through things like images and documents attached in the Messages app, review iOS Files (which are local device backups), and automatically delete movies or videos after you watch them.


Tip: You knew this was coming. Before you start wiping out large files, make sure you took the opportunity to Back Up Your Files. Thank you for listening to this public service announcement.


I mentioned this earlier, but another way to free up storage is to Optimize Mac Storage, where files saved to iCloud Drive are temporarily removed as needed and replaced with small proxy files. When you need the original, it’s downloaded from iCloud.




Don’t Be Tempted by File Compression




What if you could take a physical box of files and shrink it down to the size of a deck of cards? With digital files, you can do that by compressing them into ZIP (.zip) archives. It sounds like a great way to recover storage space, but let me wave you off that idea.

For one, SSD or hard disk space is incredibly inexpensive for storage purposes. If you’re at the point where you feel you need to scrounge for every last byte, spend a small amount of money to purchase a terabyte or two of external storage.

More important, compressing files into a ZIP archive locks them into a container that can’t be accessed without decompressing it. That black box presents two problems. First, the contents of the archive are hidden from searches, unless you’re using an app that can peer into the archive.

Second, there’s no guarantee you’ll be able to open the box later. Right now, accessing the files is not an issue: macOS, iOS, and iPadOS can work with the ZIP format. But before ZIP became a standard for file compression, StuffIt was the way to compress and archive files on the Mac. Now, when I run across a StuffIt (.sit) archive, I need to open it using StuffIt Expander, a free utility that hasn’t been updated in three years.

It works…for now. But looking ahead five years or more, will I be able to access those compressed files? Will the same fate happen to ZIP files? It’s not worth the tradeoff to regain a few megabytes here or there. ZIP files are great when sharing sets of files with other people as a way to reduce the amount of data that gets sent over the internet. Not as an archival format.






About This Book

Thank you for purchasing this Take Control book. We hope you find it both useful and enjoyable to read. We welcome your comments.


Ebook Extras

You can access extras related to this ebook on the web. Once you’re on the ebook’s Take Control Extras page, you can:


	Download any available new version of the ebook for free, or buy a subsequent edition at a discount.


	Download various formats, including PDF, EPUB, and Mobipocket. (Learn about reading on mobile devices on our Device Advice page.)


	Read the ebook’s blog. You may find new tips or information, as well as a link to an author interview.


	Find out if we have any update plans for the ebook.




If you bought this ebook from the Take Control website, it has been automatically added to your account, where you can download it in other formats and access any future updates.
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This is but one of many Take Control titles! We have books that cover a wide range of technology topics, with extra emphasis on Macs and other Apple products.

You can buy Take Control books from the Take Control online catalog as well as from venues such as Amazon and the Apple Books Store. But it’s a better user experience and our authors earn more when you buy directly from us. Just saying…

Our ebooks are available in three popular formats: PDF, EPUB, and the Kindle’s Mobipocket. All are DRM-free.
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